Running mesh 802.11s on BT HH5 router

Hi guys, been using openwrt since about 2002 on an old WRT54G but have recently caught up and installed WRT 21.02.1 on a BT HH5a using VDSL with Vodafone - took a while but got it running ok.

My plan is to have a mesh network with 4 other HH5 covering my property with Wifi and ethernet via rj45 connectors. These 4 other HH5's would mesh back into the device with is providing internet connectivity via its built in wifi and lan ports.

The other mesh units would would provide wifi access and ethernet to various remote devices all running on the same sub net but with a mixture of static and dynamic devices.

The main HH5 is connected to the Vodafone ISP and serving DHCP it also holds the static IP address table for those items which must remain static (mostly our Sonos system).

In total we have about 70 IP addresses in use 192.168.1.xxx

Now I have the 1st HH5 working, here are my questions I'm hoping some kind sole can help me with.

  1. Is the above even possible ? Specifcally can the main router do double duty and run the mesh function.
  2. Can the mesh nodes provide both wifi and ethernet connectivity ?
  3. How do I start ? FYI I did have a little dabble with a bunch of RPI 3's but quickly discovered their wifi chips don't support mesh - hence the use of HH5 devices.

I've read some guides done a lot of googling, but frankly I find it a bit over whelming - but at the same time a fun challenge to learn something new, so I'm going persevere !

I'm reasonably Linux and computer savy just not to hot on the finer points of networking.

Regards Tim

You can do, but you may well find the wifi too slow.

You'd need to replace the basic wpad with one that supports mesh, I'm using wpad-wolfssl.

I have mine set up using batman-adv as I needed the bridge loop avoidance for my particular setup, but I'd suggest using 802.11s with Forward mesh peer traffic enabled to avoid the extra complication (see: https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s )

If you intend to use 5ghz for mesh, you'll need to uninstall the CT versions of the ath10k firmware and driver as they don't support mesh and install the non ct versions :

ath10k-firmware-qca988x
kmod-ath10k

(A reboot will be required to get them to work)

Usually, I'd suggest using the development build (or RC4) as there are a number of performance enhancements for the bt-hub , but currently there's a significant booting issue https://github.com/openwrt/openwrt/issues/9829

Do you have the ability to use hardwired connections between each of your APs and the main router? If so, you'll probably have much better performance.

We live in a rural area so our back haul speed is 25mb at best, thus a slow wifi for surfing the web isn't too much of a big deal. The Sonos system runs its own mesh and plays nicely.

Noted about wpad-wolfssl, I had come across that in the guides and ok about the ath10k firmware and driver swap. I'll google how to do that.

Rather than creating a mesh system I might look into using WDS and discover the pro's /cons.

Thanks for the guidance.

Regards Tim

Hi, I already have a couple of hardwired access points, but running cables to other areas is not easy / feasible hence I thought I'd go wireless and accept some reduction in through put.

I'd even thought about running some fibre optic ethernet cables, but the size of the connectors, routing and terminating them would likely prove difficult.

Regards Tim

One thing I forgot to mention is you'll probably want to avoid using 5ghz channels with enforced radar detection, as I find they tend to shut down, or else switch channels (if you configure that) when using several routers, I suspect the other router's wifi signal may sometimes be being misidentified as a radar. ( "iw phy0 info" for a list)

If it is any help, these are the current settings for my 5ghz mesh using batman-adv. To use 802.11s routing which is best to get working first before trying batman-adv if you need it, you'd want to change mesh_fwding=1 and change the network (presumably to lan).

I changed the last octet of the wifi mac addresses of each router to make it easy to identify which router's are connected to each other (01,02,03 etc).

config wifi-iface 'mesh0'
        option macaddr '00:90:01:08:16:01'
        option device 'radio0'
        option ifname 'mesh0'
        option mode 'mesh'
        option mesh_id 'mymeshssid'
        option encryption 'sae'
        option key 'xxxxxxxxxx'
        option mesh_fwding '0'
        option network 'mesh_5ghz'
        option disassoc_low_ack '0'
        option skip_inactivity_poll '1'
        option mesh_rssi_threshold '1'
        option mesh_gate_announcements '1'
        option reassociation_deadline '20000'
        option max_inactivity '15'

I haven't tried wds, as mesh worked well enough for my needs (I needed an alternate method to connect to an external camera that's built in wifi was effectively being jammed by a neighbour's wifi).

1 Like

Thanks for the quick reply and guidance - I've just upgraded the 5GHz drivers as you suggested and had started to edit the config files and will roll in your suggestions.

I'll go off and learn about enforced radar detection as I've not come across this before.

To test the mesh I need to create another node so for test purposes I'll try an RPI3 either that or buy another HH5 from somewhere as I'm not confident I could make an RPI3 work correctly.

Thanks again for the 'hand holding' - got a lot to learn, hard to believe 20 years have passed since I first installed openwrt and how things have changed !!

Regards Tim

Yes and yes.

Read this:

You are very likely to ever get an RPi working with 802.11s mesh, because you cannot get a USB dongle that can reliably support mesh.
In addition, RPis are expensive when you add up all the bits and pieces, fine to play with if you have one already (except for this use case it will not work).

Buy, instead, a low cost OpenWrt router (eg gl-iNet MT300N-V2 for £27 new on Amazon in the UK).

If you are in an ETSI region (~Europe), running a mesh on 5GHz can be problematic due to DFS. Stick with 2GHz, particularly if you are in a quiet rural area where you can run 40 MHz channel width to get double bandwidth (300Mb/s).

1 Like

Thanks Bluewavenet - more useful information.

My plan is to use 5GHz for the mesh and 2.4GHz as AP's as some devices are 2.4GHz only.

OK about the RPI's I must have spent a couple of days messing with them as an image was available and I have a 'box full of RPI's of various flavours' - they are now consigned to other projects.

As for hardware I think using HH5's through out might be the best bet as this would likely reduce maintenance and other issues.

This raises another question - would it be possible to use exactly the same image / config on all of the HH5's, but only one of them would have access to my ISP provider via the WAN / VDSL2 modem ?

This way I could have a spare ready as a back up / expansion if needed, plus HH5 are very cheap at £10

I did take a look at the gl-iNet MT300N-V2 but it seems to be 2.4GHz only so not suitable for my needs. FYI I'm located in the UK.

Regards Tim

Ofcom relaxed the rules on 5ghz in 2020 to allow use of channels 149 - 165 without DFS, so now channels 36 - 48, or channels 149 -165 (both 80mhz) would be suitable here in the UK.

Although if you decide to run an access point on 5ghz as well as a mesh, the 149-165 band isn't supported by many devices.

The Mesh settings are the same on all devices. as mentioned previously I do change the default mac address of each mesh so I can identify each router without memorising each of their unique mac addresses.

Until recently, I'd been compiling my own image with the required modules included and 5ghz wifi drivers replaced and at one point, I did include much of my config files, and changed the IP settings, gateway and dhcp settings of each after flashing, although now I either just keep the settings, or restore a backup from one of my other routers and tweak them in the UI.

Thanks for the info regarding Ofcom, very useful.

Just for clarity, so each node can use the same image ,with the same config files for WAN, LAN, Wireless and Mesh (not just mesh config) - but changing the last digit of the Mesh MAC for id purposes on each node. Correct ?

Sorry to be a pain but could you post all your config files (WAN, LAN, Wireless and Mesh) suitably sanitized so I can compare them to mine in case I've missed or screwed something up (very likely !)

I'm running WRT 21.02.1 but have not yet installed batman-adv just wpad-wolfssl, maybe I don't need batman-adv, time will tell.

I think I'll take the plunge and order some more HH5a's in anticipation of Mesh success :slight_smile:

Regards Tim

The WAN settings don't matter on the routers that are only used as mesh nodes, I set gateway in the lan settings on the nodes to point to the one plugged into the phone line, and disabled their dhcp servers.

I've been using DSA builds for over a year, something I can't currently recommend as recent builds are very unstable due to the bootloop issue, so my network settings would just confuse things. It is also possible that some of them are a bit messed up as a couple of my routers got stuck in a boot loop after trying a recent snapshot and I used an old backup, and they were more of a case of getting it working, rather than a good example, as my networking knowledge is negligible.

I'm also using batman-adv, partly because two mesh nodes are also connected by ethernet cable, which would cause a bridge loop. These are the relevant sections

Wireless
...
config wifi-iface 'mesh0'

        option device 'radio0'
        option ifname 'mesh0'
        option mode 'mesh'
        option mesh_id 'mymeshssid'
        option encryption 'sae'
        option key 'XXXXXXXXXXXXXXXXXXXXXXX'
        option mesh_fwding '0'
        option network 'mesh_5ghz'
        option disassoc_low_ack '0'
        option skip_inactivity_poll '1'
        option mesh_rssi_threshold '1'
        option mesh_gate_announcements '1'
        option reassociation_deadline '20000'
        option max_inactivity '15'
...






Network
....

config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms '1'
        option ap_isolation '0'
        option bonding '0'
        option fragmentation '1'
        option gw_mode 'off'
        option log_level '0'
        option orig_interval '1000'
        option bridge_loop_avoidance '1'
        option distributed_arp_table '1'
        option multicast_mode '1'
        option network_coding '0'
        option hop_penalty '30'
        option isolation_mark '0x00000000/0x00000000'

config interface 'mesh_5ghz'
        option mtu '2304'
        option proto 'batadv_hardif'
        option master 'bat0'

If not using batman-adv, add "mesh0" to the lan instead of "bat0" and use these in the wireless "mesh0" settings

	option mesh_fwding '1'
	option network 'lan'

(Even if you intend to use batman, I think it is easier to get everything else working without batman-adv first).

I'm sure you'll find better guides in the forum etc.

Thanks for taking the time to write such a detailed reply.

I've managed to get one mesh point up and running with connectivity to my ISP, but can't be sure until I receive my other HH5's and set them up. I think I'm on the right track thanks to your help, reading various posts and most importantly reading the guide documentation.

One thing I did have to do was to use a ethernet WAN connection to my original modem DMZ as I found the HH5 VDSL modem would frequently drop / re-sync whereas my Vodafone modem would go for days without dropping.

At some point once I have the mesh working ok I'll revisit using the HH5 modem to see if I can get it to work more reliably.

Regards Tim

You would probably benefit from the Lantiq VDSL fixes included in the development branch and 22.03 RC4, which are reported to resolve stability issues on vectored lines and other bugs.

See:- Vectoring on Lantiq VRX200 / VR9 - missing callback for sending error samples

Unfortunately, as I mentioned, the BT hub 5 can get stuck in very prolonged boot loops with both at the moment.

Thanks mjs

I'm pleased report that my mesh system is up and running with two nodes - just waiting for some more HH5 to arrive to expand mesh.

ok about vectoring - I think once I have the mesh running ok I'll delve into updating the dsl side of things - I'm a glutton for punishment !

Many thanks agian, Tim

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.