Rtl-sdr package

Hi all,
thanks for this big project!
I came across OpenWrt as I like to take old electronic bricks and put them into new life.
With a old Pirelli modem, I was able to install the adviced version of the OpenWrt.
The purpose of this device it will be solely to make a RTL_TCP server in a remote location that has internet available. Installation has been succesful through the serial port and all seem ok.
The only problem is that in the available packages, I can't see and I can't get any rtl-sdr stuff.
Any suggestion will be very welcome.

1 Like

It doesn't work.
I've tried many times, no success.
I've also tried via command line at SSH prompt, no success.
In the update packages list, rtl-sdr is not there, hence no install doable...


You'll need to build it from sources.

Click on Sources in the last column of the package table entry.

Will try tomorrow, going bed now, very late for me.
Thank you very much, will post any progress.


Can you please show what exactly you are doing?

Package page shows rtl-sdr was released in 21.02.0

OP may be using an earlier version...since there was a mention about installing OpenWrt on an old Pirelli device.

No, the package page doesn't show the date of first release.
The RTL-SDR package exists at least since 14.07.

How should the release info be interpreted?

OpenWrt release: OpenWrt-21.02.0
File size: 43kB
License: GPLv2
Maintainer: Vasilis Tsiligiannis
Bug report: Bug reports
Source code: Sources

@bobafetthotmail Can you answer this question?

I was updating from command line, without finding proper files for manual install.

Anyway, sorted.
I'm a absolute noob on OpenWrt, the version loaded at first attempt was a old 10.xx
I have now a 21.02 and Rtl package was there and installed.
Noneless, I have some strange glitches that I still have to figure out.
Occasionally the router kill the service or it goes into strange behaviour.
Perhaps limited performance of my Pirelli hardware?


Possible...your device only has 32 MB of RAM, and a 300 MHz CPU -

1 Like

I can confirm, I've attempted running rtl-sdr on a device with 560 MHz CPU, it had issues. Sampling rate could be adjusted to help.

Things to note:

  • Remember the bandwidth of your SDR (basic ones can be as wide as 2.8 MHz), lowering this setting when operating/sampling will save CPUs
  • Lowering the sample rate will lower CPU usage

Thanks mates,
I had same thoughts and applied practically with good resoults. Reduced sampling to 1.024Mb and is decently usable. I also turned off a few services to reduce cpu load.
I have to mention that to make it work properly I had to downgrade gradually to version 19.04
This version hold variations once rebooted and is capable of accepting boot start of the RTL_TCP stack.
Quite happy of the results, after all is just a piece of electronic junk.
My neighbours were quite happy to get rid of.
One more candidate has arrived today, Huawei HG553, looks promising and better performances of Pirelli AGPF. Will try :wink:


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

that just means that it's available in a specific OpenWrt release, to see if it was available for older versions, click on the "Source" link to go on github and then click on the button with "openwrt-21.02" on the top left to open the menu of all OpenWrt versions (which are handled as branches on git).

Then you can select any old version and see if the package exists or if Github gives you a "file not found".

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.