RT-3200 gaming issue (wifi, random latency spikes)

Hello all!

I recently picked up the Belkin RT-3200 and was able to successfully flash OpenWRT on the device. Everything seemed to go very smoothly which is always a plus. However, I seem to have one small issue with the device and that has to do with gaming. I currently have a Netgear A7000 Wi-Fi adapter I use in my desktop for connectivity.

I connect to the 5GHz band (currently channel 36, 80MHz) and I get great speeds. However, when I play a game (have tested in Rocket League and Apex Legends) my ping will spike randomly (think from 40ms - 170) and I will sometimes get the packet loss warning. This will randomly happen for a second or two and then be fine for maybe 30 seconds and happen again. I have tried changing Wi-Fi channels, band width, set up SQM and even tried with 2.4GHz and the same issue occurs. The strange thing is if I hook up a spare router I have (Google Wi-Fi) instead via Wi-Fi everything is fine. No ping spikes or packet loss issues. Anyone have any idea of some settings I need to tweak or look into? I'd much rather use OpenWRT if possible. Any help or insight is greatly appreciated!

Tested with a 50 foot Ethernet cable and have no issues connected via Ethernet. I have even tried creating a new SSID and having only the desktop connected to Wi-Fi and the issue persists. So in my mind it has to be some setting that isn't set correctly. I hooked up the Google Wi-Fi to check the channel and channel width and matched those in OpenWRT (Channel 36, 80MHz) and I still get the random ping spike/packet loss issue. Any ideas?

Assuming your client PC runs Windows, check how you can disable wifi background scanning for new stations. You might need special add-on software for that.

Also, make sure your 5GHz radio uses a channel with minimal interference/overlap with any others in yor area, and does not require DFS (https://www.wi-fi.org/knowledge-center/faq/what-is-dynamic-frequency-selection-dfs) in your region.

You might also want to try to reduce your 80MHz channel bandwidth to 40MHz and see if that positively affects latency variance.

Lastly, nothing will beat wired Ethernet. Use it whenever you can.

Could you please provide more information about your OpenWrt configuration? the snapshot release number will tell us the version of the MT76 driver you are using, and your /etc/config/network and /etc/config/wireless files could provide a good insight into your current configuration. Just edit personal info such as MAC, password, etc.
One of my routers is an E8450 (the same hardware) and I never had those hiccups, and I am using 160MHz channels.

Thank you for the suggestions, I will definitely look into those. I would love to run an Ethernet cable, but to do that I would either have to run the 50 foot cable directly through the middle of the apartment or get one that is longer and snake it around the ceiling which may end up being the way to go anyways.

No problem, see below:

login as: root
root@'s password:

BusyBox v1.35.0 (2022-03-30 14:20:50 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r19345-72b93b77a5
root@OpenWrt:~# /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fddf:d501:c6a9::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns ''
        list dns ''
        list dns ''
login as: root
root@'s password:

BusyBox v1.35.0 (2022-03-30 14:20:50 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r19345-72b93b77a5

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wmac'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
        option country 'US'
        option channel '6'
        option txpower '20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'REDACTED'
        option ssid 'REDACTED'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option country 'US'
        option cell_density '2'
        option txpower '23'
        option htmode 'VHT80'
        option channel '149'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'REDACTED'
        option ssid 'REDACTED'
        option dtim_period '3'

I changed the 5GHz band to channel 149 to see if that made any difference and unfortunately it did not. Let me know if I can provide any additional information and I will be happy to! Thank you!

Do you need the 2G radio on?

Unfortunately I do as I have some IoT devices that require it. I thought maybe those devices were somehow causing the issue so I created an entirely new SSID and ONLY connected my desktop to the 5GHz to test and experience the same issue.

Are they cameras?

Smart plugs and bulbs.

Ok nothing require huge bandwidth.

Who's further away from the router? Will they do 5G?

If you're the far point out put them on 5G, you take 2G@40H

Look again at your neighboring spectrum/adjust (6 is dead center praying 1 and 11 aren't spamming) and hope it works.

Running 2.4 GHz at 40 MHz can negatively impact your neighbors WiFi.

I wouldn't do it.

I would agree.

Test at 40, and then 20.

Use a WiFi analyzer app to see who is using what channels in your area, your signal strength, and your signal-to-noise ratio (SNR).

Yeah I'm gonna keep the 2.4 @ 20.

Have just tested 5GHz at both 40 and 20 and changed from 36, to 48, to 149. Sadly same result. One sort of odd thing I just noticed is that when I look at the details for the 5GHz band it currently shows my channel at 149, signal at -50 dBm, but the noise is 0 dBm. I changed channels and the noise always stays at 0 dBm for the 5GHz band however looking at the 2.4GHz band it is reporting the noise correctly. Is that just a bug with the snapshot or could this point to something else?

We have a similar configuration. I only see some differences in the DTIM and power limit.

Why are you reducing the maximum power of your radios? The driver default for the 2.4GHz band is 28 dBm and 24dBm for the 5GHz band. You have reduced your power 8dB in the 2.4GHz band. That means you are using only 15% of your maximum power. My advice for you is to remove the option txpower lines. Optionally you can also remove the dtim_period line. Nonetheless, it is ok if you leave it there.

have you scanned the bands around your home? 80MHz in the channel 36 won't interfere with radar, same for the contiguous 80MHz starting at channel 149.

If you are building your own image, sharing the /etc/build.info file could provide more data about potential issues between packages.

That is the expected result. Please note that the 36-48 is the same 80MHz contiguous band. So, it doesn't matter, selecting 36, 40, 44, or 48 will make the driver to use the same 80MHz contiguous band. This diagram will help you to visualize the possible 80MHz contiguous groups you can use, along with the other possible bandwidths:

I have correct SNR readings, and you should too, but only when there are devices connected to that radio. Otherwise, the reading will be zero.

I see you are using a very recent snapshot. Are you building your own image?

Why are you selecting those channels? Have you scanned the radios before selecting the channels?

Your config looks similar to mine but I keep my 5g at channel 36 but my spectrum is pretty much greenfield because I'm out in the middle of no where. What about software/hardware offloading? I know there have been some hiccups with some of those pieces at times.

I used to get weird delayed association with wireless clients in builds prior than say... 3 weeks ago.

It is probably overkill and might even be a bit of a NOP but I do have irqbalance enabled on mine plus these in rc.local due to a (potential) AQL issue that I believe is being looked into by quarky.

echo 437500 > /sys/devices/system/cpu/cpufreq/policy0/scaling_min_freq
echo "schedutil" > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor

echo 0 > /sys/kernel/debug/ieee80211/phy0/aql_enable
echo 0 > /sys/kernel/debug/ieee80211/phy1/aql_enable

Knock on wood but my 2 APs/routers have been solid with the builds from snapshot from the last few weeks.

1 Like

And on my desktop, I have my Intel wifi configured to use (under Win11):
Intel AX200 card in desktop:

Global BG Scan blocking - Always 
MIMO Power Save Mode - No SMPS
Roaming Aggressiveness - Lowest
U-APSD support - Disabled

(I know U-APSD and MIMO Power Save are GoodThings(tm) to enable but I have run into corner cases with this card related to those settings)

This assumes it is more 'desktop-y' than 'mobile' otherwise if it was a laptop, I'd probably remove the Global BG setting since the laptop goes to places other than my house.

That is a good advice. Irqbalance is fine for saturated traffic, not very common in a home environment, but it doesn't harm. Raising the minimum freq and changing the CPU scheduler are also good advice, and I have the same settings. However, I believe leaving the 300MHz instead of 437.5MHz is perfectly fine and it would run even colder. I want to try it.

I am not so sure about disabling AQL. There are some side effects when doing that in saturated environments. That solution was proposed taking into account the problems of the R7800 hardware. The R7800 is a different animal. I have also an R7800 and it is nightmare compared to the smooth ride of the E8450/RT3200.

I am not disabling AQL and I am not having any issue. Most probably that setting is not helping in this platform.

Maybe I'm getting my wires/threads crossed but I'm pretty sure there was potentially something odd going on with AQL with RT3200 as well. I'll have to check in the morning.

As far as 300mhz being avoided, it is so I can use schedutil scheduler without risk of a known quirk.

Since it sounded like a small-ish house type of install for gaming, I figured these were worth checking out in case it makes a difference for their scenario but if I were concerned about gaming latency, I'd be hard wired.

I don't have many devices that use the 2.4GHz band and the ones that do aren't doing anything bandwidth heavy so I am not as concerned about those devices so I figured I'd turn down the power on that band. I have since reverted that change.

I have scanned the channels around me and since I live in an apartment my environment is pretty noisy. Channels 36 and 149 seem the best in my environment which is why I choose those.

I am not building my own image as I set up the RT3200 with the instructions provided here: https://github.com/dangowrt/owrt-ubi-installer

I then ran the Attended Sysupgrade through the GUI to get the latest version.

I am selecting those channels because after scanning for networks around me those seem to be the best in my environment.

I have a few devices connected to the 5GHz band, but am still not seeing the correct SNR in the GUI for some reason.