RPi Zero + OpenWRT unable to connect to dashboard | Home Network

Hi everyone,

I have an RPi Zero W, an Ethernet/USB Hat by Waveshare and I flashed the latest version version (23.05) of OpenWRT for the Zero W to an SD card.

I inserted the SD card and upon boot-up the lights are on and everything seems to boot properly (the green light on the RPi board starts blinking and then goes static). I connected a CAT6 LAN cable to the USB Hat and the other end into my home router (speedport).

The problem is that OpenWRT doesn't appear anywhere in the network and I can't access the dashboard (I downloaded the factory install .iso of OpenWRT so Luci is pre-installed). I checked in ipconfig as well as in the speedport router dashboard itself.

The ipconfig page in CMD of my PC shows '' as the standard gateway, in the etc/config/network file (in ubuntu) I set-up the following values:

option ip addr '' (other devices in the network are in the range)
option gateway ''

What I also tried is adding option ignore 1 in the lan section in the etc/config/dhcp file and I also tried connecting to my home Wi-Fi by entering the corresponding SSID and psk in the wireless config file.

I don't have the possibility to directly access my RPi yet, since I need to procure a mini-HDMI adapter first, I had just hoped that I could access the dashboard on my PC which is also connected to the same router.

I also tried plugging the LAN cable into the back of my PC instead of the router, same result. There is just a weird IP adress being assigned ( nothing else...

Your help is greatly appreciated !

Did you install the driver package for your usb Ethernet adapter?

Also, it isn’t clear - did you change the ip address of your pi (in the openwrt config) to use the correct subnet? The default address is

1 Like

I don't have access to the dashboard in OpenWRT, how could I install the driver package, is there a way to insert it to the SD card directly ?

In the OpenWRT network config the gateway is set to '' since that's my home routers gateway address the netmask is ''.

So when I look it up in ipconfig on my PC the gateway address (my PC was assigned by DHCP) is '' and not ''...

You can include the driver using the firmware selector by requesting a custom image. You just need to know which driver is needed.

Meanwhile, changing the gateway is not sufficient. You also need to change the address that the pi is using.

Use firmware selector, and include the required driver first.

Ok, I will try flashing the SD with the packages "kmod-usb-core", "kmod-usb-net-rtl8152" and "usbutils" included (I'm pretty sure the USB/Ethernet HAT has the 8152 chip).

The IP address I entered in the OpenWRT network config file is: option ip addr '' (other devices in my network are assigned IPs in the range)

1 Like

Little update: so I reflashed the SD with the .iso inlcuding the above mentioned packages and still nothing.

I've already ordered a HDMI to HDMI-mini adapter and probably will have to access the RPi interface directly to find out what exactly is going on...

If you added usbutils, try lsusb to get the VID and PID of the adapter.

Or plug it into a PC or similar.

The problem is not only that.

I also tried adding a wi-fi-iface with my home wifi ssid and key and it doesn't connect either. At least it doesn't appear in my network device list of the router providing wi-fi.

Of course the RPi board has an integrated wifi module

The onboard wifi is crap, at best, and I'm pretty sure the packages supporting it, aren't part of the standard build.

I see.

I'll be able to tell you more tomorrow and then post an update here.

Thank you for all your answers for now

So, I just connected my RPi to a display and connected a USB keyboard to the above mentioned Waveshare LAN/USB hat.

Everything works fine.

For lsusb I'm getting Bus 001 Device 004: ID 0bda:8152 Realtek USB 10/100 LAN

Other devices are my connected keyboard for example.

ip a shows the following:

inet scope host li

It's like it's not connected to the ethernet but the cable is plugged in...

when you installed kmod-usb-net-rtl8152, did you also install the r8152-firmware package ?

What's the command for listing installed packages ?

opkg --help

Yep, r8152-firmware - 20230804-1


pull the USB ethernet dongle, run logread -f, reinsert it again, and post the output (if any).

Unfortunately it's not a USB dongle it's a HAT using pins to connect removing it is not very easy.

However logread -f doesn't anything but in logread f I found the following expressions:

DNS rebinding protection is active, will discard upstream RFC1918 responses!


Allowing responses

you wrote it in the 1st post, sorry.

do the logread again, pull the ethernet cable, and reconnect it.

While logread -f was active I removed and re-connected the cable.

Nothing appeared. Exited by pressing ctrl+c