Routerstationpro refuses factory upload

after a few years of using LEDE 17.01.0 a time has come to upgrade my routerstationpro.
I decided to do the factory flash, so I rebooted the router to the recovery mode, ping works ok.
The upload itselft seems to be ok:

tftp -m binary -c put openwrt-22.03.2-ath79-generic-ubnt_routerstation-pro-squashfs-factory.bin
sent DATA <block=15646, 512 bytes>
received ACK <block=15646>
sent DATA <block=15647, 330 bytes>
received ACK <block=15647>
Sent 8011082 bytes in 4.1 seconds [15566645 bit/s]

But that's all. The router does not do anything even it is expected to process the upload and reboot itself. Pings are still replied.

Any idea?

Does LEDE still boot properly? If so, just upgrade using the normal sysupgrade feature. You'll need to do it in several steps, which is obviously an annoyance compared to the one-step factory process.

I'd recommend going from current 17.01.0 (ar71xx) > 18.06.9 (ar71xx) > 19.07.10 (ath79) > 22.03.1

Start with your system in the default/factory reset state on 17. For all upgrades, do not keep settings.
When you go from 18 > 19, you will be changing targets, and you'll probably get a big scary warning that the image is not supported. Just make sure the checksum matches the expected one from the downloads page and that you've grabbed the correct image (routerstation pro, never the regular routerstation).

Once you're on 22, you're golden.

Yes, it does.

Somewhere on the way there was a release that bricked rs pros (I was told by a friend of mine but I don't have any links or details). That's why I wanted to just do a big skip to 22.

Btw is there any reason for the factory not to work? I thought it was a clean install erasing everything.

I have been using OpenWrt on my RS Pro for quite a while, and I've never had it bricked via a standard upgrade. There was a bug in either 19 or 21 (early versions) that caused eth0 to drop down to 100Mbps... that was resolved and is not an issue in the later versions and in 22.03. In fact, the only time I used the TFTP recovery process was in the effort to debug that very issue (I flashed a bad image).

The recovery process worked without issue when I did it, but I don't want to take my RS Pro out of service to try again and document the process. I can tell you that I was using a Mac and entered the commands individually, like this:

tftp> connect
tftp> bin
tftp> put <filename>

I'll give it a try as soon as I have a little more time.

But I still don't get why a fresh factory does not work...

Your upgrade path worked like a charm!

I had to force twice:
18.06.9 -> 19.07.10:

# sysupgrade -F -n openwrt-19.07.10-ath79-generic-ubnt_routerstation-pro-squashfs-sysupgrade.bin 
Invalid image. Contents do not match checksum (image:5b6b05a5a1d4761180cafeb7eca62f7f calculated:7e8ea8ccb65be40960fc0646e152a5f9)
Image check 'platform_check_image' failed but --force given - will update anyway!
Commencing upgrade. Closing all shell sessions.

19.07.10 -> 22.03.2:

# sysupgrade -n -F openwrt-22.03.2-ath79-generic-ubnt_routerstation-pro-squashfs-sysupgrade.bin 
Device ubnt,routerstation-pro not supported by this image
Supported devices: ubnt,routerstation-pro - Image version mismatch: image 2.0, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Partition design has changed compared to older versions (19.07 and 21.02) due to kernel drivers restrictions. Upgrade via sysupgrade mechanism is one way operation. Downgrading OpenWrt version will involve usage of TFTP recovery or bootloader command line interface.
Image check failed but --force given - will update anyway!
Commencing upgrade. Closing all shell sessions.

Now I'm on 22.03.2 and happilly routing! :slight_smile:

1 Like

Fantastic. Great to hear!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.