Require ssh password?

After installed openwrt I accessed the router by ethernet and there is no web interface so I accessed by commoned line and require SSH password . I tried all my guesses and also I tried to leave it blank. it's still refuse. My router model is tl-wr840n v2.
What should I do?

OpenWrt has no password set by default (user:root, password:hit the enter key) and requires you to set one. If config remains from the previously installed firmware interfere, see https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

For anything 'based on OpenWrt', your guess is as good as ours.

3 Likes

Serial connection have no default password function activated.

1 Like

It's ssh connection

If you're using ssh, you need to set a password.

passwd
1 Like

I don't know.it requires on ssh connection password. I tried to reset router but still require

Can you connect using a web browser?

What file did you install onto your device? (what was the exact filename, where did it come from)?

1 Like

Yes I can access by web

Are you able to gain access via the web? Does it require a password?

1 Like

No It doesn't require on web

ok... make sure you are ssh'ing with the username root:

ssh root@<router-ip-address.>
1 Like

Yessssss
It is

What do you mean?

Where did you get the file that you installed?

1 Like

From a open wrt website

My router model is tlwr840n v2

from "a" openwrt website, or from "the official" openWrt website? (this is critical)?

Please provide the link to the exact file that you used.

1 Like

Offical website

I just want to write a little command line can I do that by any other ways or from web access?

Since you cannot access your system via ssh, let's see a screenshot of the followig:

System > Administration > SSH Access
1 Like