Report Devices Here With 18.06.0 Provided Image too big to save overlay

So, now that WNR2000v4 has been reported, could the WIKI for that device be changed? I just installed the recommended firmware from there (18.06) and it has the overlay problem. Also, has anyone compiled a new firmware for that device without the PPP and IP6 packages? I tried using, but it just says "building firmware" and spins forever.

Yes, I have noticed too, that my DIR-615 Rev.D3 wasn't storing any configuration after the update. I just reverted back to chaos calmer 15.05.1. I tried using the imagebuilder to remove some stuff (ipv6, LUCI) but the profile isn't there for 18.06 and I don't think that router has much left to offer anyways so I didn't bother.

Best advice: convert all your 4MB flash devices into AP like the wiki says, or use them as unmanaged switches.

For 18.06.x you need the ar71xx-tiny imagebuilder, not the normal ar71xx variant (stripped down kernel and other space saving efforts to make it hopefully fit); but 4/32 MB devices are on their last leg (and 15.05.x really is horribly insecure and shouldn't be used anymore).


I didn't even know that there was a stripped down builder. That router on 15.05.1 was used exclusively as a dumb access point after another router without WiFi and were both replaced by a C7 about an year ago. Right now it's in my drawer and I was fiddling last week with my vpn setup/config and got it out as a test subject.
Fun fact: with 15.05.1 I can get openvpn as a client installed (ram), but the throughput is so bad, you are going to toss the router :sweat_smile: Otherwise, I'd use it as a Client-Bridge for my sat receiver which sadly has no WiFi but ethernet.


in both cases mean being vulnerable to KRACK (among other known security flaws), particularly the client-bridge.

Running it as VPN appliance would be even worse.

I'm not paranoid to people hacking me since
a. the range of DIR 615 wasn't that great to begin with. I can confirm the WiFi signal doesn't even go outside the house since I have those good old concrete walls and floors.
b. I'm always connected to a vpn when using the openwrt network. The VPN is run either on the device or on the router, just as I have setup the C7 to do. So you may get in, but you won't be able to do much to my traffic.

I got same issue of image too big error , but I got a perfect image with latest updates by manipulating the kernel parameters like MTDPARTS and append/ padding for fixing boundaries

Is this something related ?

Please use this topic only for what it is meant for: Reporting devices.

For any questions, please open new topics (and perhaps link them to this topic here).


1 Like


If you're having problems with a specific router, if there isn't a thread for that device, you can start one and get some help on "putting your firmware on a diet." There isn't going to be any "magic" solution for devices that simply don't have the required resources for a full build of current, robust OpenWrt firmware.

For 850re v2 check my post at the end of this thread:

Not as good as an official openwrt release but works with enough free space left to save a few configs.

1 Like

@jow Now that several devices have been reported here that lose configuration after a reboot, what are we going to do now with those devices?

Since we know that they don't work as expected with 18.06, I propose to take the respective 18.06.* images offline, and suppress 19.07 image generation (or take them offline after generation, whatever is easier to implement).

What do you think?

1 Like

I agree with that. Do we already have a condensed form of the devices listed here?

Sure, here is what I could exctract from this topic (and other topics that are linked to this one):

This posting is wiki, i.e. everybody can edit it for adding more affected devices.
Please make sure to only add devices with 4MB flash.
Devices with 8MB flash are not affected and shall not be added to this list.

Brand Model Topic link / Comment
Cisco Valet M10 Linksys e1000 failing to install 18.06.1 firmware
D-Link DIR-300 B5
D-Link DIR-300 B1
D-Link DIR-615-D1
D-Link DIR-615-D3
D-Link DIR-615-H1
EnGenius ESR-9752 / ESR-9753 OpenWrt 19.07.0 first release candidate
Linksys E1000 v1 same Hardware as Valet M10
Netgear WNR612v2
Netgear WNR1000v2 and v2-VC Community Build available.
Netgear WNR2000v4
On Networks N150R
TP-Link TL-WA750RE v1 [SOLVED] TL-WA750RE factory reset on reboot
TP-Link TL-WA850RE v2
TP-Link TL-WA855RE v1
TP-Link TL-WR840N v5
TP-Link TL-WR841ND v8 Flashed rom changes aren't persistent
Sitecom WL-351 v1.002
Unbranded A5-V11
Unbranded wr512-3gn
ZyXel Keenetic v1

Unfortunately no idea, how to edit the previous post:

A further failing 4MB flash device is:
Brand: D-Link
Model: DIR-615-D1

1 Like

Edit button at the bottom right of the post. Just added it for you.

I've got a tp-link wa850re v2 with overlay issues and a tp-link wa850re v1.2 with NO overlay issues (running OpenWrt 18.06.2). Not sure if that sheds any light on the question whether problems with overlay are size issues...

In any case, I've created a thread here

and I'm happy to investigate if someone can give me pointers what to look for.

TL-WR840N V5 also resets itself after reboot.

This is already known, see the list above.

dir-600 b1 also

Please add affected devices to the table above. The posting is wiki, i.e. everybody can edit it and add more affected devices.