Flashed rom changes aren't persistent

I've flashed a dump for my router(wr841nd v8) thanks to @juppin you can see the full thread here(9 replies, very short) [SOLVED] Wr841nd debricking

Now, it looks like my changes aren't surviving a reboot, here's what I did to eliminate all variables

  1. rebooted the router
  2. $echo abracadabra > /etc/config/test
  3. $cat /etc/config/test <- shows abracadabra
  4. $reboot
  5. $cat /etc/config/test <- no such file or directory

any ideas as to why this happens and/or how I can fix it?

Thanks for your time!

4M flash, it is standard behavior.

can you please expand?

Your router has only 4M flash, and it is not recommended for using OpenWRT.

this router ran chaos calmer for a few years before I bricked it... the dump I received comes from a running router with "lede reboot", I'd say it can run at least some versions of openwrt :wink:

https://openwrt.org/supported_devices/432_warning

2 Likes

read it, I'd be happy if I could get the router to run as a repeater :slight_smile: tho right now it can't save even a few bytes...

df shows this as output, for what it's worth

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2304      2304         0 100% /rom
tmpfs                    14088        56     14032   0% /tmp
/dev/mtdblock3             320       260        60  81% /overlay
overlayfs:/overlay         320       260        60  81% /
tmpfs                      512         0       512   0% /dev

I recommend you to build image with settings already specified.

1 Like

thanks!

I tried flashing a chaos calmer image, when running bootm, it still boots from lede, looks like even if I build a custom image, it won't be used somehow...