Recovering a bootlooping Netgear WNDR 4300

I have a Netgear WNDR 4300 that is in a bootloop after flashing a new sysupgrade firmware.

Assuming that the reset button that the tftp upload instructions refer to is the button on the bottom, I cannot seem to get this thing to boot into tftp upload mode. There is no point where just the switch LEDs come on, and trying to press and hold at various times never results in a flashing power LED or even the bootloop stopping.

FWIW: here's a video of the bootloop if it makes it any easier to visualise/diagnose.

Unfortunately I don't have a JTAG to connect to the console to see what's going on.

Any ideas?

Serial console.

1 Like

Can I get a serial console without a JTAG on this router?

Try this;

Step 2: Placing the Router Into Recovery Mode 

Start by turning off the router using the power button on the back of the device. Now, using the small object of your choice, press and hold the "Restore Factory Settings", also known as the Reset button located on the bottom of the router (there is a red ring around it). While holding the rest button, turn the router back on. Continue to hold the reset button for approximately 45 seconds then release it. 

** NOTE: Before you release the reset button, just be sure the power LED light on the router is flashing Green. If it isn't, continue to hold it for about another 15 seconds until it is flashing. 

Then refer to here re: serial access;

https://openwrt.org/toh/netgear/wndr4300#oem_installation_using_the_tftp_method

For brevity, what is the name of the image that you tried?

@anon50098793 Bingo! Your steps were bang on. The steps in this wiki page could really stand to be clarified I think. I have done that.

Additionally, it seems it's important that the cable be plugged into a LAN port before the router is powered on (with the reset button being held down).

As for the image I flashed, it was one I built myself with the imagebuilder. But I have built and rebuilt this same image many times before. The process is entirely scripted so I should be getting repeat[ed|able] results -- albeit with just more recent packages -- each time I do it.

Moreover, using tftp to flash the exact same image that bricked it using sysupgrade worked just fine.

Anyway, I am hugely greatful for your assistance here. You have helped me recover my bricked router.

There can be bad compilations and also bad flashes.
It happens every now and then.

Yes, indeed. This one must have been a bad flash since using tftp to flash the exact same firmware file was successful.