Recover Archer C6 v2 EU

Hello everybody,
I recently approached the world of OpenWRT and I successfully installed the version recommended by the wiki on my Archer C6 v2. Not satisfied with the performance, I modified the boot partition with Breed to try to overclock the CPU (the router in question is a spare router from a few years ago and I was aware of risking bricking it).
Before flashing the boot partition with a Breed image I backed up the boot partition and the ART partition of the flash memory, in case I had problems later. Very naively I didn't do a full backup of the whole flash memory of the device.

After installing Breed the router could no longer boot and was stuck on the bootloader reachable on From there I tried to flash the firmware partition from the dedicated menu by inserting an OpenWRT sysupgrade firmware, unfortunately without solving the problem.
After this I dumped all the flash memory, as is possible from the Breed menu.

Convinced of being able to return to the previous state, I flashed the boot partition only, restoring the uboot bootloader previously saved from OpenWRT. After this operation I finally bricked the device, which turned on and worked as a simple unmanaged switch and it was not reachable on any IP address. I tried to perform a recovery with TFTP method with the procedure available at this link: Tp-Link Archer C6 V2 Revert to Stock Firmware [Guide], but the terminal didn't respond and the WPS LED didn't light up (I have already put the procedure into practice in the past during other tests that went wrong and I know for sure that it was done correctly since I was able to recover the device)

I bought an external programmer and tried to flash a firmware made up of the boot partition first, the TPLink firmware for the recovery procedure with the previously linked TFTP server padded and the ART partition on the bottom of the image: in this way the router becomes reachable at the IP and shows a recovery page asking to load a firmware. Unfortunately, whatever firmware I try to insert, the procedure stops after a few seconds and fails.

Unfortunately, I couldn't find any complete dumps online of my device model from which I could start to restore it. I was wondering if, considering that I have a backup of the uboot and ART partitions, is there a way to create a complete image or even just the portion of the image relating to the firmware that can be inserted between the boot partition and the ART so that it can be flash on the device using the external programmer.

TL;DR: Is there a way to create a full dump flash image starting from a working uboot partition, ART partition and OpenWRT/TPLink firmware?

Sorry for the long post but I tried to provide as much information as possible to better explain the problem.
Thanks to anyone who will try to help me.