Recent upgrade broke https for luci-ssl [solved]

I did an opkg-upgrade on my TP-Link TL-WDR3600 v1 where luci-ssl has been running successfully for a long while, and uhttpd started throwing a segfault inside of one of the mbedtls libraries (I'm sorry I didn't make a snapshot of the exact error, I was under time pressure to make a firewall change). I removed all mbedtls libraries and installed luci-ssl-openssl and all seems fine now. I'm just posting this to see if anybody has seen the same issue - I can reinstall luci-ssl and capture the error if needed.

It is not terribly surprising as, at least right now in v18, there isn't versioning of the "ABI" of a package (the way one package uses parts of another when running). Using opkg upgrade can end up with you getting on package from your ROM's date, and another from months or years later, which may not be compatible.

My suggestion would be to back up your router, install 18.06.02 when available, install the packages you need and adjust your configuration as needed. If you're upgrading from a version prior to v17, you will likely need to configure by hand, rather than just restoring your current configuration.

OK, it gets weirder... I uninstalled everything with 'ssl' in the name, reinstalled 'luci-ssl' and now https is working again.

Gotcha on doing the full the upgrade when available, I bought this router to run OpenWRT in Dec. 2014, did every upgrade include a trip to Lede and back...

@mvh If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)