18.06.1 - Luci - Bad Gateway

Hi guys,

today i did an update on some packages.... uhttpd was some of them. Now i get an Bad Gateway The process did not produce any response when i try to open the web interface.

i tryed some old uhttpd and luci configs without success. and a reboot.

any ideas

router: linksys wrt3200acm


It is generally recommended to avoid doing package updates unless absolutely necessary as it can sometimes cause conflicts with broken dependencies, kernel versions, and so on.

What packages did you update? Do you have a backup of your config?

Can you SSH into your router? If SSH works, the best way to recover may be to simply run firstboot (which will reset everything back to defaults) and then restore your backed up config.


ssh works, internet still works, it is just a normal opkg update, nothing special.
i tryed old configs from a backup, but still cannot get the web interface.

it looks like the uhttpd dosent come up. maybe the bad gateway was from an cached file in the browser.

@psherman is spot on -- you have probably broken package dependencies where one or more had their ABI change. See Recent upgrade broke https for luci-ssl


i found this just now:
Thu Jan 31 18:46:05 2019 daemon.info procd: Instance uhttpd::instance1 s in a crash loop 6 crashes, 11 seconds since last crash

in logread

sorry what is spot on and how can i proof this ?


Did you run opkg update, or opkg upgrade? opkg update is necessary to update the package lists, but it does this in RAM and does not change any package files (just the lists, that's it). If you ran an opkg upgrade, that probably broke things.

As mentioned earlier, if you just ssh into the device and run firstboot, you'll probably get everything working again and you can restore your previous backup.

"spot on" -- English phrase meaning "exactly correct"

Save your config, upgrade to 18.06.02 (or reinstall 18.06.01), install any additional packages you need, confirm that it works

In general, do not run opkg upgrade until ABI-compatibility checks are present in OpenWrt. Until those checks are present, installing an upgraded ROM and a self-consistent set of packages is highly recommended for most users. A specific exception for this would be, for example, direction from a trusted member of the OpenWrt development team, not just some user on the forums (This is an example, do not do this now!), "All users running v17 or later should upgrade dropbear to resolve security issues. Users of versions prior to v17 should upgrade to v18.06.02 or later." (This is an example, do not do this now!)

1 Like

opkg update

opkg list-upgradable

opkg upgrade *packagename

This is what broke things.


This potentially broke your kernel, drivers, and many other things you haven't found yet.

I would, back up your config (twice), get into failsafe mode, run firstboot to completely wipe your router to defaults, restore your config, and go from there.


Was there some specific reason you were trying to upgrade the packages? As @jeff and I have both been saying, this is usually not necessary and will likely break things, so unless you have a very good reason to upgrade packages, you should just wait until a new stable release version comes out

You're currently running 18.06.1 -- you should fix this with firstboot.

Wait until 18.06.2 (due out very soon), then upgrade to that. This ensures that package dependencies and kernel versions and such will all be self-consistent. Do not use opkg upgrade (ever, unless there is a specific and good reason to do so)... perform an upgrade to .3 when it comes out sometime in the future.


okay thanks guys for your help i thought it is like an normal system update on other devices... shame on me.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.