RCP error after trying to set up access point with a static IP

Hi I have recently configured a Raspberry Pi 4 as an OpenWrt router. I have used Linux for years but I would not describe myself as anything other than a beginner. I like to experiment though and try to do so following guides on forums like this. I am learning a lot with Openwrt but I dont properly understand networking terminology or practice. The guides here are often are too technical for me.

I have got my router working on my home network. I have set up my old ISP router as a wireless access point for the router. I tried to set the wireless router as a dumb access point. DHCP and DNS is turned off. I tried to give the wireless router a static IP address using the Luci Static Routes method. Following this I have an RCP error when I try to access Interfaces and Static Routes on the Luci "network" menu.

Both my Raspberry Pi and my wireless access point appear to be working normally.
How might i resolve the RCP error.

Thanks in advance.

Looks like your changes left a corrupt configuration file. Does "uci export" produce any error message?

1 Like

Hi thanks for responding. I have 1 error lines in the output from uci export. It says

uci: Parse error (invalid command) at line 37, byte 1

Here it is in its immediate context in the export dump

config internal 'diag'
	option dns 'openwrt.org'
	option ping 'openwrt.org'
	option route 'openwrt.org'

uci: Parse error (invalid command) at line 37, byte 1
package p910nd

config p910nd
	option device '/dev/usb/lp0'
	option port '0'
	option bidirectional '1'
	option runas_root '0'
	option mdns '0'
	option mdns_ty 'My Printer Manufacturer_Model'
	option mdns_note 'Basement'
	option enabled '1'
	option bind '192.168


I am not sure what this is telling me.

There is also an error message generated in Luci when I click on interfaces or static routes.

RPC call to uci/get failed with ubus code 9: Unspecified error
  at handleCallReply (

Thanks again for any help.

Your /etc/config/network or /etc/config/wireless are the likely culprit. One of those two files contains a syntax error near line 37.


Thank you.
There was an error near line 37 of the network file. I had configured an interface with the "list dns" option. I had used upper case instead of lower case. As soon as i put it right the error disappeared.

May I ask two more things.
Are RPC errors usually in these two config files or can they be in any of the config files?

As you may have noticed the error happened after I had configured some changes in the Static Routes option of the Network menu in Luci. I was trying to configure a static ip for my dumb wireless access point.
Is this the right place to configure a static ip for a device on my Lan like the access point?

Thank you once again for the help from both of you.

The LuCI gui will not produce invalid configuration, the error must have been introduced by you editing the file manually using an editor or some scripting.

LuCI RPC errors (which are related to uci/get, uci/set) are usually related to syntax errors in the underlying file and can theoretically happen with any broken configuration file.

1 Like

Thanks that is helpful.
It was definitely introduced by me. I remember adding the line but somehow failed to notice I was adding it in upper case. I also checked the file multiple times looking for errors and still failed to notice it. Thanks again.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Hi there
thanks for pointing to the way to mark this as solved. I will definitely do this, I was just waiting to see if there was any response to my second question about whether the luci config tool for static routes was the appropriate place to create a static ip for my wireless access point?
thanks again.

A dumb access point should not need any route configuration, as it does not create any new networks. If you just needed to give it a static IP address, go to the "Network" > "DHCP and DNS" > "Static leases" page.

Apologies for the delay in replying. I have been busy elsewhere for a few days.
Thanks so much for the reply and the advice. Really helpful.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.