RAVpower Filehub AC-750 does not install luci in terminal


I am new here on this forum. I bought a RAVpower AC750 (WD009) Filehub and flashed OpenWRT onto it. But what I noticed is that the Web interface was not active, so I had to login via SSH to the filehub with ssh root@ from the terminal.
A port scan of revealed open ports 22 and 53 and filtered ports 80 and 443, so indeed web access did not work.
According to the documentation in 'Luci essentials' (https://openwrt.org/docs/guide-user/luci/luci.essentials) I had to enable Luci via the ssh terminal with the command opkg update which failed.

I first found after searching on the internet and did this in an SSH session:

uci set network.lan.ipaddr=''
uci set network.lan.gateway=''
uci set network.lan.dns=''
uci commit
service network restart

Then I plugged the ethernet cable into the router and it had internet now with the new IP address. The command 'opkg update' worked now.
But then it had dependency problems after issuing 'opkg install luci':

root@OpenWrt:~# opkg install luci
Installing luci (git-20.113.70804-9d02ef1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/luci_git-20.113.70804-9d02ef1_all.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci:
 * 	kernel (= 5.4.52-1-2f9fa99c65f56f7fc4487f8ba69512eb)
 * opkg_install_cmd: Cannot install package luci.

How can I get around this ?

BTW, I cannot log in on the wiki of OpenWRT while I do have an account (otherwise I cannot post topics).

You need to flash the most recent snapshot image (only stable images have the web interface built-in, by the way). Then you'll be able to install packages through opkg. Snapshot builds are cycled frequently, and a new build often means you cannot flash kernel related packages on an older build.

As for the wiki, anyone can create a login. Or you can use your GitHub handle if you'd like.

1 Like

Thanks, I already found out before you answered and succeeded to install Luci.
Now it works, except that I cannot mount an HDD and an SD card together, see my other topic I just opened.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.