Raspberry Pi4 with eth0 and eth1 (usb) and wifi

Hi,
I have been using OpenWrt on my Raspberry Pi4 for a time now, but never got to a point that I would have working WIFI on RPI4 as well. I attached some old TP link router which is giving me WIFI in the same subnet as my LAN.
I would like to enable wifi on RPI as well. I can connect to wifi, this works. I think I have problems with settings in /etc/config/network.

Here is my /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3c:cdf5:e91a::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'wlan0'
        option ipv6 '0'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.88.1'
        option broadcast '192.168.88.255'
        option device 'eth0'
        option ipv6 '0'

config interface 'wan'
        option proto 'static'
        option ipaddr '98.130.218.220'
        option netmask '255.255.0.0'
        option gateway '98.130.0.1'
        list dns '8.8.8.8'
        list dns '8.8.4.4'
        list dns '1.1.1.1'
        option device 'eth1'
        option hostname 'router'
        option ipv6 '0'
        option type 'bridge'

Can somebody suggest how to get wlan0 to be in the same subnet as my LAN and have access to WAN?

Grega

Remove this

Instead create the SSID in wireless section and assign it to network lan.

2 Likes

And change this to option device 'br-lan' in the lan interface section.

2 Likes

Thank you. It works!
grega

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.