Raspberry PI4 Generic MAC80211 802.11nac Device is not active

Hello dear team ,

I am fighting since 5 hours to make this working .

So I got a raspberry pi 4B that's was previously used with octoprint .

I wanted to change the OS for another project and try to install openwrt .

I am struggling to turn on the wifi on and I tried by SSH too with the command wifi up radio0 .

Also something is strange because he can see only the 5GHZ .

I tried to solve the issue using USB dongle with RTL8188EU drivers but same issue .

The only way for me to update openwrt is by wifi because I am backpackers .


I follow all above and same issue
Hope someone will be able to help me .
thx .

I'd recommend installing OpenWrt 21.02.1 for the Pi4B (64-bit or 32-bit, if you haven't already done so.

Then follow this guide for enabling the onboard wifi:

If you're using a dongle, you will need to install the appropriate package (rtl8188eu-firmware - 20211216-1 - RealTek RTL8188EU firmware). Keep in mind that not all dongles support AP mode, and even if they do, the performance may not be particularly impressive. The Pi's built-in wifi will not make a good AP, either, but it should work.

iw reg get
uci show wireless
dmesg | grep -C3 -E '(hostap|wpad|suppli|wlan)'

not enough information... you want a client? an ap? on ? band ?

not enough information... channel analysis? see rpiAP from a client?

When I try to the turn the wifi on he stay as disable ,I tried to turn on with the website interface but still in Generic MAC80211 802.11nac

Device is not active
for the onboard wifi .

He can see only the 5GHZ band very strange .

i will take a break for few hours and come back thx for your help both

looks like you've not been looking in the right places

or search the build thread or forum for 'country'