Raspberry Pi 5 not booting

Downloaded the latest (dev) build for Raspberry pi 5, installed onto SD card, but during boot I get these messages, but no logon prompt.

Also, I cannot connect to it via SSH or even ping the ip address.
I picked up the IP address from my list of active devices on my router.

I only have one ethernet connection plugged directly onto the SBC eth0. Is the boot process waiting for the second connection?

Connect a keyboard and hit enter. What happens?

Alternatively, disconnect your pi and your computer (including disabling wifi) from the network, then connect the pi directly to your computer and then try to connect ssh root@

1 Like

Thank you. I pressed enter on the keyboard and got eh message:
WARNING! There is no root password defined on this device.
Use the "passwd" command to set up a new password.....

When I enter passwd, I get a response back:
/bin/ash: sw: not found.

I guess I have to return the the manual to see where to go from here. I have no knowledge about the ash shell.

It looks to me like you may have made a typo. Try again and show us what happens with a picture of the screen (if you’re using the keyboard connected to the pi; a direct screenshot or even better copy/pasted text is best if you are using ssh)

You always get this warning on firstboot and then every boot until you define a PW.
You can ignore it and then plug in an ethernet cord attached to a device and browser into

After that you can configure and add the password.

Please close this issue - I think I am past the "not booting problem"

It will close in 10 days after you mark it solved.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.