Raspberry Pi 4 released

Still not working. Here is my config.txt file

# OpenWrt config
include distroconfig.txt

# Place your custom settings here.


# PoE Hat Fan Speeds

And here is the log:

Wed Jun 24 00:06:21 2020 kern.err kernel: [    6.781403] rpi-poe-fan rpi-poe-fan@0: Failed to get default PWM value: -5
Wed Jun 24 00:06:21 2020 kern.warn kernel: [    6.788289] rpi-poe-fan: probe of rpi-poe-fan@0 failed with error -5
kmod-pwm-bcm2835 #? ( or this kmod-hwmon-pwmfan )

Installed both, still not controlling fan after reboot.

from afar that seems to be 97% of what you need... so best to hitup the vendor or rpi forums... and rule out a config issue ( could also be done with raspbian + dtc dump + lsmod )

1 Like

Thank you very much. Maybe some future update will fix this. I'll wait.

I don't know if this is the right place to ask or I need to start a specific thread, but as this one seems generic to the pi4 I will ask here and it can always be deleted if required.

First up is an easy one, which rpi4 do I get for openwrt use? 2GB should be enough, but should I future proof a bit with 4GB or go mad and get 8GB just because it's there?

Next up is more tricky, how do I go about updating the openwrt when needed? Can you use the sysupgrade packages still or do you need to remove and reflash the SD card each time??

What package do you use to monitor CPU useage and temperature?? Your little graphs are excellent :grin:

I am using MRTG from snmp.

1 Like

I'll have to look into trying to install that as it's a nifty little ability... I love all these monitor widgets.

I installed luci-app-statistics and it has monitors for quite a bit of stuff.

For updating I have 2 sdcards that I'll run off one, when I update I build the image the install it on the other power down the pi and switch them. But it don't know if there is the ability to do an in-place upgrade, from my reading I have only found something about not doing it with openwrt.

Once you have OpenWRT installed and running on a SD card you can should just be able to use sysupgrade, either through LuCi or the CLI, as normal. I've had no issues doing it with an EXT4 sysupgrade image.

1 Like

I see the turris omnia router has 2gb ram so I guess that's enough, so I'll get one ordered and have a play... If I think I need more ram I'll get another and this one can be a pihole server lol

I have the 2gb version and have 94% memory free.

Not even after resizing your ext4 partition? Mine says every time that it has to do a "new install" because of the new partition layout.

@Thebroughfamily, BTW, having the 4 GiB version gives you 2 GiB on the /tmpfs which can be advantageous if you keep a lot of logs, data captures or you process big files, e.g. prepopulation of Unbound cache.

1 Like

Yeah, did it once with a resized partition with no issue. Now I just compile my own image with a bigger partition to save having to resize.


Maybe I'm doing it wrong, but if I update using the upgrade image:

  1. My SD Card is repartitioned to the default and I have to mount it in a PC to repartition as I want
  2. As I have wan connected to USB2ethernet adapter, internet connection is lost until drivers are installed (so I have to install them using manual methods)

If kmod-usb-net-rtl8152 was included in the base and /dev/root used 10Gb that would be a tremendous help.

This is what happens to me with the partitioning layout of the SD, gets back to default even using sysupgrade images. [sigh]

In regard to loading the module automatically after the upgrade, may I advice you to create your own sysupgrade image using Image Builder? It is very easy and will solve your problems, even if the SD card gets wiped every time, it will help circumvend a bit these issues.

I have no linux machine (or VM) to install Image Builder. Each OpenWRT platform has its own specifics, being the pi4 so "generous" in flash & ram I really don't understand why its standard images aren't built for SD's with at least 16Gb and do not include all existing kmod-usb-net-*

Where can I make a formal suggestion ?

Could be because of the size of final binary. If my memory serves me well when I tried to changing partition size while compiling source code myself with make menuconfig I ended without space in my OpenWrt VM as my SD was 64 GiB and it created dd-able images of this size. :frowning:

I wondered the same thing.
There are a lot of packages I think should be included because there is tons of space.
Especially more network drivers.

Why doesn't someone do a community build like others do for other routers? I've used the @hnyman build on my R7800 for ages, he adds the basic functionality most people require, along with a few commonly used add-ons like adblock, ban-ip, SQM etc... And every week or so updates the build to the latest versions for people to download as either a factory image or sysupgrade.