Raspberry Pi 4 released

Figured it out. Install kmod-hwmon-rpi-poe-fan

1 Like

I am using that one: https://www.amazon.ca/gp/product/B00MYTSN18/ref=ppx_yo_dt_b_asin_title_o07_s00?ie=UTF8&psc=1
Just install the driver: kmod-usb-net-asix-ax88179

1 Like

If you use a usb powered hard drive and a usb to ethernet adapter you might need a usb powered hub also.

From what I've tested the Pi4 doesn't have enough power on the ports to stably power both.

Had a few kernel panics and loss of internet a few hours into testing with both stock Realtek r8152 driver and the updated version.

1 Like

Hi everyone,

I tried to find information on how to install squashfs image onto the sd card, how do you do?

I'm currently using the ext4 and wishing to switch to squashfs =)


EDIT: Is using dd like I do with ext4 images correct?

EDIT2: It's seems using dd is working after extracting img file =)

Did you manage to control the fan ? Mine is running continuosly. I have kmod-hwmon-rpi-poe-fan installed.

Yes, my fan cycles on and off. I didn't do anything special - I just installed the kernel module.

I am using Wulfy23's community build described in this thread: Rpi4 < $(community_build)

1 Like

fwiw: community build does not alter config.txt so a stock release with that kmod should yield identical results... ( the build does include userland tho' but I doubt that would have an effect )

wonder what;

dtc -I fs -O dts /proc/device-tree | grep -C5 poe

says? (re: trip points) ( edit: sys is probably a better place to poke around )

If this helps
cd /sys/devices/virtual/thermal/thermal_zone0
grep -H [0-9] trip*

Gives this:


1 Like

If it's anything like previous Pis, the 5v USB rail is directly tied to Vin, so it's not the Pi4 that is the problem, it is your power supply.

(However, past a certain limit you might need to power the Pi from the GPIO header instead of the USB input.)


I do have the official 5v 3A power supply which I thought should be fine.

is there any tool in openwrt for pi4 to monitor adsl/vdsl modem stats using telenet?

whats the difference between suqashfs and ext4 i think i installed openwrt using ext4. Is there any benefit?

I installed openwrt on microsd and everything worked fine but when I try to install it on external ssd nothing works. What is the procedure to make openwrt work on external drive?

vcgencmd bootloader_version
 Mon Aug 24 11:47:50 2020 daemon.err nlbwmon[2539]: Unable to dump conntrack: No buffer space available
 Mon Aug 24 12:10:34 2020 daemon.err uhttpd[2457]: luci: accepted login on / for root from
 Mon Aug 24 12:11:25 2020 daemon.warn dnsmasq[4166]: possible DNS-rebind attack detected: canaryeastasia1.eastasia.cloudapp.azure.com

Please tell me what are these errors? what is this DNS rebind attack detected Please help me what should i do now? I just logged in via ssh from CMD

Hello I need to know what packages i need to download to use USB drive as FTP server and also use smb to access files from it inside windows. And how to setup password for it

Here is what I did to get an RPi 3B to work. Just to be on the safe side, I installed modules/drivers for seven commonly used USB ethernet adapter chipsets, including some gigabit chipsets. Mostly because I saved the image to use for friends, so it works out that I can share this procedure and support pretty much any USB to ethernet adapter. Also I kept running into a problem where the logs were flooded with messages about not being able to set the CPU clock speed. This would wear out the flash, and it made it nearly impossible to find anything in the logs, so I set the min and max clock speeds to 600mhz, and also set that in the config.txt.
I'm currently on a 50mbps internet connection and I setup OpenWRT on this Pi as a VPN client. I can fully max out my connection and the CPU rarely breaks 1% usage, even though its under-clocked to 600mhz. I have yet to test this on a faster connection. Theoretically you should be able to max out VPN throughput to wire speeds without having the CPU as a bottleneck, even at 600mhz. Also the CPU on an RPi4 is going to get more done at a given clock speed. Under-clocking also reduces the power consumption.

This is done with OpenWrt 19.07.2 r10947-65030d81f3 / LuCI openwrt-19.07 branch git-20.057.55219-13dd17f

Also I use a TrendNET TU3-ETG USB3 to gigabit adapter, it is common to find them for less than $20 US. Its not made in China, and the chipset is made in Taiwan... because from a moral perspective China seems to be doing their best to make Nazi Germany look like saints.

Here is the short version of what I did, connect a screen and keyboard to get this done. Also you'll want to use the onboard NIC for your LAN in case something happens to the USB device.

After you login...

uci set network.lan.ipaddr=192.168.168.xx
uci set network.lan.gateway=
uci set network.lan.dns=
service network restart

#DO NOT uci commit as this just makes a mess to clean up... restarting the network services uses the above values, restarting the PI reverts to a functional router.

Once you have it talking to your LAN...

opkg update
opkg install nano kmod-usb-core kmod-nls-base kmod-usb-net kmod-usb-net-cdc-ether kmod-usb-net-rndis kmod-usb-ohci kmod-usb-uhci kmod-usb2 usb-modeswitch kmod-usb-net-asix-ax88179 openvpn-openssl luci-app-openvpn
opkg install kmod-usb-net-mcs7830 kmod-usb-net-pegasus kmod-usb-net-rtl8150 kmod-usb-net-kaweth kmod-usb-net-rtl8152 kmod-usb-net-sr9700


From the web interface, add the following line to the startup in openwrt:
echo 600000 > /sys/devices/system/cpu/cpufreq/policy0/scaling_min_freq

Added the following lines to config.txt using an SD card reader on my PC:

#As a router, 600mhz X4 cores should be plenty. Also trying to get rid of errors setting CPU freq.


Also I forgot to mention that I'm using one of those metal cases that acts as a heatsink, its very durable. Running the pi at 600 mhz means it doesn't generate much heat LOL.

They make them for the Pi4 now, Vilros has them.

Although with that case it would probably be fine to put this in some overheated place in the summer and not have any problems.

Greetings everyone. Got my hands on the Rpi 4 last week and look forward to using it as the router here at home. I have a few questions for the veterans here.

  1. Reading around and came upon an old post which talks about optimised compiling. How much of an impact does it make for a device ours (compared to the standard snapshot)?

  2. I recently attempted (and managed) to compile an image on the pi itself (took hours obviously). I wanted to see if the -march=native -mtune=native flags worked within the menuconfig. How do I go about looking to see if it worked (at all if not accurately).

  3. Out of pure curiosity. Is it even possible to run Open-WRT entirely in RAM and use the sd card for logging and backing up settings and such. If it were possible would it not increase the life of the sd card (or ssd for the adventerous)?

p.s looking forward to learning a lot from all of you.

  1. for such a powerful device, why bother... set min_freq to max and call it a day
  2. check your make logs
  3. possible with an initramfs... with good sdcards less than $20AUD/$12US unless you are mounting it as an 'installation' in some hard to reach remote place... again, why bother (ok, an uber secure / tripwire type setup would be another use)? just make sure anything (custom installed that is) data heavy is working on tmpfs and you'll get more life out of your sdcard than if it were in a phone...