Raspberry Pi 4 released

only if i knew it earlier :frowning_face:

i was thinking to buy this switch sg108e then i saw simple cheaper switch from tplink LS1008G
btw i got in to openwrt just for SQM so i don't get lags in games when other people are also using internet and went with pi4 instead of buying new router

Don't worry, while using VLANs works (if internet access is <= 500 Mbps) having the traditional two interfaces is much easier to wrap one's head around...

1 Like

i have much lower speeds 5% of your mentioned speeds :frowning_face:

Has anyone figured out how to get the PoE hat fan running on this build?

Figured it out. Install kmod-hwmon-rpi-poe-fan

1 Like

I am using that one: https://www.amazon.ca/gp/product/B00MYTSN18/ref=ppx_yo_dt_b_asin_title_o07_s00?ie=UTF8&psc=1
Just install the driver: kmod-usb-net-asix-ax88179

1 Like

If you use a usb powered hard drive and a usb to ethernet adapter you might need a usb powered hub also.

From what I've tested the Pi4 doesn't have enough power on the ports to stably power both.

Had a few kernel panics and loss of internet a few hours into testing with both stock Realtek r8152 driver and the updated version.

1 Like

Hi everyone,

I tried to find information on how to install squashfs image onto the sd card, how do you do?

I'm currently using the ext4 and wishing to switch to squashfs =)


EDIT: Is using dd like I do with ext4 images correct?

EDIT2: It's seems using dd is working after extracting img file =)

Did you manage to control the fan ? Mine is running continuosly. I have kmod-hwmon-rpi-poe-fan installed.

Yes, my fan cycles on and off. I didn't do anything special - I just installed the kernel module.

I am using Wulfy23's community build described in this thread: Rpi4 < $(community_build)

1 Like

fwiw: community build does not alter config.txt so a stock release with that kmod should yield identical results... ( the build does include userland tho' but I doubt that would have an effect )

wonder what;

dtc -I fs -O dts /proc/device-tree | grep -C5 poe

says? (re: trip points) ( edit: sys is probably a better place to poke around )

If this helps
cd /sys/devices/virtual/thermal/thermal_zone0
grep -H [0-9] trip*

Gives this:


1 Like

If it's anything like previous Pis, the 5v USB rail is directly tied to Vin, so it's not the Pi4 that is the problem, it is your power supply.

(However, past a certain limit you might need to power the Pi from the GPIO header instead of the USB input.)


I do have the official 5v 3A power supply which I thought should be fine.

is there any tool in openwrt for pi4 to monitor adsl/vdsl modem stats using telenet?

whats the difference between suqashfs and ext4 i think i installed openwrt using ext4. Is there any benefit?

I installed openwrt on microsd and everything worked fine but when I try to install it on external ssd nothing works. What is the procedure to make openwrt work on external drive?

vcgencmd bootloader_version
 Mon Aug 24 11:47:50 2020 daemon.err nlbwmon[2539]: Unable to dump conntrack: No buffer space available
 Mon Aug 24 12:10:34 2020 daemon.err uhttpd[2457]: luci: accepted login on / for root from
 Mon Aug 24 12:11:25 2020 daemon.warn dnsmasq[4166]: possible DNS-rebind attack detected: canaryeastasia1.eastasia.cloudapp.azure.com

Please tell me what are these errors? what is this DNS rebind attack detected Please help me what should i do now? I just logged in via ssh from CMD