Raspberry pi 4 eth sharing

my main AP the RE450 seems to be limited to 100Mbps download since changing to WPA2/WPA3

upload speed to 170Mbps

ISP paid for speed is 200Mbps but we get around 200-210Mbps

Set encryption to WPA2 and cipher to CCMP. Set channel width to 80 MHz. Test again and report back. Post your config files as described above.

I think there may be a fault with the Ethernet cable or something

Download is around 50
Upload is around 190

I think I had that issue before and it was the Ethernet cable

The raspberry pi side is not getting above 50mbps at the minute

What about my post above? Step by step.

I will try that if replacing the ethernet cable does not help

image
thats my main AP settings, that the raspberry pi is connecting to

getting less than 100Mbps

Your settings look ok. I can't think of any other easy attempt to fix this.

You can try connecting your RPi to another device, like personal hotspot from mobile phone or laptop, to see if you get similar speed.

It would be great to setup iperf3 tests. Install iperf3 and run iperf3 -s on one device and iperf3 -c server.ip.add.ress and then iperf3 -c server.ip.add.ress -R on the other side of the connection.

its not just the Raspberry Pi its all devices now since I messed with he settings yesterday

I clearly have some form of interference

its impossible to get above 30Mbps on a mobile phone signal here

iperf is not going to able to measure from the main AP and thats all we need to focus on at the minute

why is the download speed much lower than the upload, the connection is 200Mbps download and upload

if the main AP is not right, the raspberry pi never will be

can power adapters cause wireless issues

I have lost access to LuCi again, the STA stops working and the whole system is not reachable, even though ethernet

Yes. What made you think is may be a power issue?

Hook a monitor and a keyboard up on the Pi so you can terminal in on it when it goes down next time.

ISPs know when you are using speedtest sites and, routinely, inflate speeds to make them look good.

Those are all legitimate theories.
Use the process of elimination and tell us your results testing each.

I have power adapters nearby and they seem to drop the download speed

Not in this case
I have seen 200Mbps in task manger on windows
ISPs don’t do things like that, well not here for sure
Never heard of anything like that

I will also try to access LuCi from my laptop again

The interference seem to have been cause by power adapters for other devices nearby

Moved some things around, it’s better but not as perfect as it was last year

The raspberry pi got around 170Mbps before completely crashing

I never showed the configs, I will do that sometime today

ubus call system board


{
        "kernel": "5.15.134",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 3",
        "model": "Raspberry Pi 4 Model B Rev 1.2",
        "board_name": "raspberrypi,4-model-b",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.0",
                "revision": "r23497-6637af95aa",
                "target": "bcm27xx/bcm2711",
                "description": "OpenWrt 23.05.0 r23497-6637af95aa"
        }
}

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd53:ebd2:a8ca::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wwan'
        option proto 'static'
        option ipaddr '10.42.0.200'
        option netmask '255.255.255.0'
        option gateway '10.42.0.1'
        list dns '10.42.0.252'

config interface 'bridge'
        option proto 'relay'
        option ipaddr '10.42.0.200'
        list network 'lan'
        list network 'wwan'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3:1.0'
        option channel 'auto'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'SSID'
        option bssid 'BSSID'
        option encryption 'sae'
        option key 'PASSWORD'
        option skip_inactivity_poll '1'
        option disassoc_low_ack '0'

Just thought I would update you

It’s stable, but not seeing above 50 Mbps on the raspberry pi

The main AP is back at full 200Mbps

Can anything be improved further as I did see 170Mbps on the raspberry pi, don’t know if it was correct or not

50 Mbps on what radio?

cat /etc/config/wireless

I already sent that above

Radio 0 is onboard
Radio 1 is the usb adapter

So radio 1 is the one I am using

I can’t use onboard as DFS is non existent on the raspberry pi 4

1 Like

I have to ensure we are on the same page and It is just easier to get fresh results.
Let me look this over.

Please run the speedtest from speedtest.net.

the latest wireless config is exactly the same but here it is anyway

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option channel 'auto'
        option band '2g'
        option htmode 'HT40'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3:1.0'
        option channel 'auto'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'SSID'
        option bssid 'BSSID'
        option encryption 'sae'
        option key 'PASSWORD'
        option skip_inactivity_poll '1'
        option disassoc_low_ack '0'

speedtest
its proved me wrong like it always does
yesterday I was getting less than shown here
https://www.speedtest.net/result/15992223295

No big deal, things change which is why we ask for 'now' results; still not the ~>200 you want.

This is wireless-dongle client to ethernet no switch. Do I remember that right?

AP is set to 80 width too, right?
What is the signal dBm and noise dBm on radio2 today?

Using LuCI channel analyzer, how many other APs are you overlapping?