R7800 performance

Hi, guys. I'm not technical so I'm here looking for help.

I'm trying to use cake and piece of cake on my R7800. I have one gig download and when I turn on SQM using cake, my download speeds take a huge hit. Down to 200MBps. When I use fq_codel and simplest, my download is around 500 down. Is there a switch I need to flip to have the same download speed as fq_codel?

I'm on wan,wan6 (eth0.2), 750000 is my traffic limiter. My CPU is on ondemand via startup/local. I already have A+ across the board via dslreports. Should I just be happy with fq_codel and simplest? I prefer to use cake and piece of cake. Thanks in advance.

Cake is much more CPU intensive. CPU power in R7800 will not be enough for 1 Gb/s traffic with cake.

Not sure if you need anything to manage download at all. Usually the upload is more limited and is the possible bottleneck. You might try leaving download unmanged and just manage upload.

1 Like

Hi everybody, can someone summerize the situation? some posts are very old.
The best solution about this may stay in the first and updated post.
I will replace/link this summary in this general collection topic I'm building about r7800
@ hnyman: some optimization are o are not included in you last firmware?
Thanks a lot!!!

ps: I have both a r7800 with actually hnyman firmware (stable branch) and a gigabit line. I can make tests, just ask me (and explain how to do them:D)

Their age doesn't invalidate the information, the situation is still exactly the same as it was 3 years ago. The hardware hasn't changed either, just the availability of >>100 MBit/s WAN connections has increased sharply.

Hi slh, I explained bad.
I just mean that, on one hand, some posts may contain problems, tests and/or solutions that are outdated because of the introduction of new openWrt release; other posts, on the other hand, contains or checked solutions that everyone should apply or unsolved problems.
So, a summary (that should be placed in the first posts, if possible), may help everybody to jump and easily contribute to the hot posts/topics of the thread.
Maybe this is not possible, I understand.

Just an example. This:

echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
echo performance > /sys/devices/system/cpu/cpufreq/policy1/scaling_governor

Should always be been done? May be a fundamental step??

If you are running 500mbps or lower speed from your ISP the r7800 is a solid all in one. I’d just recommend CPU tweaks + software offloading. If you have quicker speed or are looking to maximize QoS speed - I’d use the NSS enabled builds.

  1. CPU + firewall software offloading: Performance governor or more aggressive ondemand settings will yield the best performance for max effort 5ghz wifi and NAT (I have both in my startup script for testing, on demand is commented out). Personally I’m using the performance governor:

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

# Ondemand Governor Tweaks
# echo 800000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
# echo 800000 > /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq
# echo 20 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
# echo 60 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor
# echo 1000000 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_rate

# Performance Governor
echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
echo performance > /sys/devices/system/cpu/cpufreq/policy1/scaling_governor

  1. Interupts: I’ve tried a variety of combos. I’ve found that adjusting the interrupt CPUs makes the interrupt even-ness look pretty but doesn’t translate in to any major performance gains over the default. I run irqbalance and don’t worry about it.

  2. NSS enabled builds - activates the two hardware offloading NSS 800mhz CPUs and makes the r7800 capable of full line rate and ~900mbps NSS Fq_codel


Hi ACwifidude, if I undestand well reading your suggested links, you build already has everything ready for >500mbps (my need)?

Yep. Feel free to load my build and see what you think. You should just have to put the performance governor in the startup script and have good performance.

The NAT performance is impressive with the hardware offloading. I’m hooked. :sunglasses:

Now ... how do we get max performance and stability out of wifi in AP mode? :slight_smile:

I have tried the latest NSS build from ACWifidude and I cannot get more then 550 wired connection on speedtest on my Centurylink 1GB symmetrical connection.

All setting is default, added the performance governor on start up, added my vlan201 and my Centurylink PPPoE connection.

Any help will be appreciated?

Turn software offloading off in the firewall section (if it isn’t already). Use speedtest.net or similar bandwidth specific test to get a representation of max speed.

Made a new community build with that exact goal. I run two r7800s as APs (I like fast roaming and max performance). If you got tips and tricks to make it better I’m all ears:


Software offloading is off. Speedtest is still coming back the same on wired. Hmm...

I don’t have PPPoE or additional vlans in my setup. Post your config for what changes you’ve added and we could probably troubleshoot to see what the deal is.

Yeah, right now it is pretty simple. Trying not to bork it while working from home. Looks like I can't embed multiple screenshots since I am new.


echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
echo performance > /sys/devices/system/cpu/cpufreq/policy1/scaling_governor

Is set up via PPPOE

Most likely it is because I don’t have the NSS PPPoE driver in my build. I’ll rebuild tomorrow with it and it should solve your issue. :sunglasses:

1 Like

ACwifidude, do you have instructions on how to get your build that has NSS support? I’m using latest vanilla build right now, and with fq codel it can’t use the full speed my ISP provides (400mbps). I assume with NSS this speed is obtainable with fq codel?


NSS PPPoE driver is in - give it a whirl and see what you think.

1 Like

Thank you! I got my 1GB speed back now on wired. :slight_smile:

I even did a factory reset to make sure. I tested default ondemand govenor and got line speed as well.

1 Like