R6100 ath79 porting


i've read the router netgear r6100 is not going to be supported anymore, so I cant install/use snapshots anymore.
I cant understand since has a prett decent 128mb nand and 128mb ram.
Btw if anybody is taking care of it porting the code to ath79 I can test new builds (in the weekend).

Thanks a lot

1 Like

Add your support/interest; mailing list netgear nand patch

if/when it's committed combine with :

aerohive_hiveap-121 ( ath79 nand same soc 62db255543c8fb5d1787caf36c6c7c9c51db71cd )
no snapshot != no support

it's not exactly the end of the world for that device just yet.... but hey... if you want to bin-it you can send it to me :wink:

[OpenWrt-Devel,v3] ath79: add support for Netgear WNDR4300 -- this is "in progress" work

commit 62db255543
Author: David Bauer <redacted>
Date:   Sun Oct 27 15:49:18 2019 +0100

    ath79: add support for Aerohive HiveAP 121
commit 99835e0999
Author: André Valentin <redacted>
Date:   Wed Oct 23 11:30:30 2019 +0200

    ath79: add support for ZyXEL NBG6716
1 Like

An additional complication for the R6100 may be that unlike the other models mentioned (NBG6716, AP121, and WNDR4300), the R6100 uses the internal AR9344 100 Mb switch and PHY. There was some mention of code related to the switch being dropped-- it probably really isn't necessary with the models that use an external switch but it could be important for the R6100.

I have an R6100 which works except that the 5 GHz wifi signal is very weak, I would be willing to give it to a developer.

1 Like


I'm interested in porting the R6100 to 21.02 ath79. I could do the testing - I've got a few of those.
Is someone else interested too and would help me?

Thanks a lot


sorry if my like invokes a level of spacial time awareness from the 'community'... I'll get another device.

I too have three Netgear R6100 running version 19 and I would love to get them to release 21. What can I do to help? I can test or make documents. My linux skills are limited.

Have a look at

Hi Tom

I know how to flash the factory img file by using the reset button hold down for 25 seconds and then use TPTP to "Binary put a file".

Then I can use the Openwrt LUCI to upgrade by loading up the sysupgrade.

However this GIT link does not have these two files there. Is there some intermediate step to get to those two files?

Much appreciate help.


Did you read the whole thread, and esp the 4th post ?

Hi Frollic

I had read the complete thread but my hopes were kindled by tom pointing to git.

So, it appears that the internal switch AR9344 makes it impossible to find a path forward...

No issues. I will use these R6100 as dumb AP as and when needed on the release 19 code base.

LMK, if I misunderstood. Thanks.

Hi Tom,

I already sent you my email so that you can send me the working Release 21 files directly to me. I will try and give you my feedback. Also it occurs to me that if you post it on this forum openly, many more people can benefit from the same.


Hi Anil,

Have a look at https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=5dfa89be9900819a2796f3ff9c3f395735035f3c

The R6100 has been added two hours ago.

Thanks to Enrico and Piotr there should be soon installations files.

Love it. I will get them tested soon and post results. Thanks to Enrico and Piotr (our hero of openwrt).. and to you for helping noobs like me.

1 Like

Hi all and thanks for the effort on supporting R6100, I've just installed the snapshot via NMRPFLASH and worked fine.

Hi lumo, Hi Tom

I have tried nmr flash to load the factory image in case tftp efforts fail. So all I need is a factory image and a sysupgrade image. However, on the git, I was unable to find that. Is there something I am missing? I am a noob and not a developer.
Thanks for any pointers.


you now can find the images for r6100 in the normal OpenWRT's snapshot path that is https://downloads.openwrt.org/snapshots/targets/ath79/nand/
You should use the factory image only (at least I used only that one with the tool I posted)

Thank you so much. Will post test results, soon. I found answer to initramfs on the forum. Thanks again.

Hi everybody. I've got an error installing luci with the snapshot:
Collected errors:
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.156-1-81e0cf03d12565b340efd93ce802a72f) for kmod-nf-conntrack6

Seems I have problems doing opkg update correctly. I will re-flash with a different image in the next days and test again.

See https://openwrt.org/faq/cannot_satisfy_dependencies

1 Like