Ps4 internet speed

Hi recently install openwrt On rt-n56u
Ihave good speed on wired or wifi on all my devices except ps4 I don't know why try it on lan and wireless

Seem really weird
I'm rookie and didn't change any setting

I suspect the problem is not related to OpenWrt since all of your other devices are performing properly.

We can review your configuration to see if there is anything that might be related. You could also try rolling your device back to the stock firmware to see if the problem resolves.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thanks for reply
I'm new and Don't know much about command line but find why speed limited on ps4

To make v2ray vpn and passwall work I have to install iptables-nft and after that everything work fine except ps4 speed limited to 1/3 of actual speed
after remove iptables-nft v2ray vpn doesn't work but speed back to normal

This is quite a large detail that you left out in your original description:

Apparently you did make at least one major change of significance here.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:


sorry and thanks for reply
any solution?

Well, disable your v2ray VPN.

There are two possible reasons for why your VPN performance is lower:

  1. Most likely your router cannot process the packets (encryption/decryption overheads which are processor intensitve) at the speeds required to give you the best performance. ---> solution is to get a more powerful router.

  2. Your v2ray remote endpoint/service tier (and/or the connection between you and that endpoint) do not provide you the bandwidth you desire.

1 Like

Let me explain more
disable v2ray does not help the only way I get back to normal speed on ps4 is removing iptables-nft

When I use v2ray and instal iptables-nft everything normal on my phone or pc and get good speed the only problem is ps4 and I Don't know why

Download speed limited to 10 mbps from 40 mbps

ok... sorry, I misspoke...

if your iptables are causing a signficiant load on the processor, that is what would do it. you can run top or htop when you're running a speed test or something that is intensive and see what happens.

You probably need to get newer, more capable hardware... yours is pretty old and has a weak CPU.