Problems Mounting an External Drive

Hello,

I followed this guide to the last step to get my drive mounted:
https://lede-project.org/docs/user-guide/usb-drives-quickstart

However at the last step I received an error:

this file has been obsoleted. please call "/sbin/block mount" directly

In any case I tried "cd /mnt/sda1" but "ls" did not show anything. "mount" does not show it anywhere either.

So I tried to manually mount it with mount and I got this error (shouldn't it be auto detecting it)?

/mnt/sda1# mount /dev/sda1 /mnt/sda1
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

I tried another way using the -t -ext4 parameters and it worked. However I have these errors in the system log.

[ 9993.562721] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[43223.912298] EXT4-fs (sda1): couldn't mount as ext3 due to feature incompatibilities
[43223.920801] EXT4-fs (sda1): couldn't mount as ext2 due to feature incompatibilities
[43224.032937] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)

And I still cannot see any of the files on the drive! What am I doing wrong? In the luci GUI it's also showing it as mounted but I can't see any of the files in ssh or elsewhere.

After (successfully) mounting the drive, what is the output of "mount"?

After rebooting the router I tried mounting it again. It's not working:

root@LEDE:/mnt/sda1# mount -t -ext4 /dev/sda1 /mnt/sda1
mount: mounting /dev/sda1 on /mnt/sda1 failed: No such device

It shows up in mount points though:
53 AM

In any case here is the current output of mount:

/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/ubi0_1 on /overlay type ubifs (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
ubi1:syscfg on /tmp/syscfg type ubifs (rw,relatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)

Are there any /dev/sd* devices? Especially after unplugging and replugging, the drive may not come up as /dev/sda, it could be sdb etc. That is one of the reasons why block works by UUID.

When I cd to /dev/ I see /sda and /sda1

If you haven't already, check /mnt to see if the /sda1 mount point was actually created -

ls /mnt

if not try making one and mounting again

mkdir /mnt/sda1

It's already there.

Sorry, i missed that, hate to ask the obvious again, but your screencap from Mount Points - Mount Entry is showing /dev/sda1, not /mnt/sda1, you need to choose the Mount point directly below, if /mnt/sda1 isn't listed you can use custom, then enable this mount and save/apply.

Thanks for your help. I am a total Linux newbie if you haven't already been able to tell. So I did as you said and listed /mnt/sda1 as the mountpoint via the web interface.
52 PM
I hit apply, etc. However both df and mount do not show the device as mounted:

root@LEDE:/mnt/sda1# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 2816 2816 0 100% /rom
tmpfs 256800 928 255872 0% /tmp
/dev/ubi0_1 24084 9440 13376 41% /overlay
overlayfs:/overlay 24084 9440 13376 41% /
ubi1:syscfg 30276 468 28228 2% /tmp/syscfg
tmpfs 512 0 512 0% /dev

root@LEDE:/mnt/sda1# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/ubi0_1 on /overlay type ubifs (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
ubi1:syscfg on /tmp/syscfg type ubifs (rw,relatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)

When I cd into /mnt/sda1 none of my folders show up.

I just tested with the same instructions and everything worked fine, but, my drive never showed up in mount either even though it was showing up in Luci under Mounted File Systems and Mount Points, so it seems best to go by what Luci is showing rather than cli in this case. So, check Luci and if /dev/sda1 is showing under Mount Points then reboot. Once booted check Luci again and see if /dev/sda1 is now also under Mounted File Systems, if it is, ssh in and run

ls /mnt/sda1

and see if anything is there

That worked! So weird. And after reboot it's showing up with >mount and >df.

Bringing this issue back to life...
I think that I have the same problem, but could not understand how you fixed it.

I have a USB drive with NTFS file system.
I used https://openwrt.org/docs/guide-user/storage/usb-drives-quickstart to install the drivers

I see /dev/sda & /dev/sda1
I have the /mnt/sda1 folder

I get error when trying to mount the drive:

root@ROUTER-MAIN:~# mount /dev/sda1 /mnt/sda1
mount: mounting /dev/sda1 on /mnt/sda1 failed: Invalid argument
root@ROUTER-MAIN:~# mount -t -ext4 /dev/sda1 /mnt/sda1
mount: mounting /dev/sda1 on /mnt/sda1 failed: No such device

When using Luci it detects the drive as NTFS but still the folder not getting mounted and not showing using the mount command.
Under the list of Filesystem I don’t see ntfs (only ext2, ext3, ext4, squashfs)

Even turning the power off and on to the router does not change a thing.
The drive show up correctly under windows10, scan for error is good
How did you solved your problem?

If the drive is formatted as NTFS, you need to follow the instructions at https://openwrt.org/docs/guide-user/storage/writable_ntfs

1 Like

I've did every thing in that page and a USB drive did not mount using ntfs-3g

# ntfs-3g /dev/sda1 /mnt/sda1 -o rw,sync
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

I then connected my external drive (the one that I wish to mount) and it got mounted automatically!!!
I have no idea what was the added package that was missing (my be ntfs-3g or fdisk ?), but now I have my needed drive mounted!
Thanks

Your USB drive probably used a FAT filesystem, and could not be mounted as NTFS. I'm glad to know it works now.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.