Problem after installing firmware on WN572HP3 router

I tried to install the SNAPSHOT version (r22641-6d33afd2b6) on my Wavlink WN572HP3 router and it is now inaccessible, I tried the default ip and it doesn't work.
Can anyone help?

Tried how? Web browser? Ssh? Ping?

Snapshots don’t have the LuCI web interface installed, so the web browser method would be expected to fail.

I tried through the web browser, how do I install another firmware version?

You’ll need to use ssh to login to the router. (Username root, password is blank). Then you can use sysupgrade to install a release build.

I'm sorry for my ignorance, but should I access it through powershell?

That should work. Or use putty.

You can use ssh either from Powershell or a Windows 10 regular Command Prompt (don't use Administrator Command Prompt).

I tried this

ssh root@

BusyBox v1.36.0 (2023-04-24 02:16:26 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r22641-6d33afd2b6
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.

now I don't know the next steps

Once you’re connected via ssh:

cd /tmp
sysupgrade -n openwrt-22.03.4-ramips-mt7621-wavlink_ws-wn572hp3-4g-squashfs-sysupgrade.bin

in wget, return "operation not permitted"

Ok. You may have a connectivity issue. Easier to simply download that link to your computer (you can use a web browser) and then copy or over using scp.

Copy it to /tmp on your router.

Once there, run

sysupgrade -n /tmp/openwrt-22.03.4-ramips-mt7621-wavlink_ws-wn572hp3-4g-squashfs-sysupgrade.bin

I downloaded sysupdate but I don't know how to copy it to tmp

Use scp. I don’t know if powershell has it, but the idea would be:

From your computer, starting where your downloaded file is:

scp openwrt-22.03.4-ramips-mt7621-wavlink_ws-wn572hp3-4g-squashfs-sysupgrade.bin root@

Then on the router (via ssh):

sysupgrade -n /tmp/openwrt-22.03.4-ramips-mt7621-wavlink_ws-wn572hp3-4g-squashfs-sysupgrade.bin

Now it's accessible through the browser, thanks a lot for your help.


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.