Pre-compiled updated mwlwifi drivers for stable releases


#347

Yeah I figured that out hours later. I am currently running this setup.

**Hostname**
OpenWrt
**Model**
Linksys WRT3200ACM
**Architecture**
ARMv7 Processor rev 1 (v7l)
**Firmware Version**
OpenWrt 18.06.0 r7188-b0b5c64c22 / LuCI openwrt-18.06 branch (git-18.210.69179-6df9a57)
**Kernel Version**
4.14.54

#348

Latest release updated to 18.06.1 at https://github.com/eduperez/mwlwifi_LEDE/releases/tag/7537480.


#349

Thank you, sir. Working great here.


#350

Packages updated to commit 757340a:

  1. Added debugfs file dfs_test for DFS test.
  2. Fixed bad signal of scan results for 88W8964.

This should fix the issue on WRT3200ACM and WRT32X devices where "iwinfo" or "iw scan" would always report a wrong signal level. Packages for 17.01.5 and 18.06.1 available at https://github.com/eduperez/mwlwifi_LEDE/releases/tag/757340a


#351

Hello
I'm using Lede SNAPSHOT r7938-5dd745588e / LuCI Master (git-18.232.74480-b93d3f3)
Kernel 4.14.66 on WRT32X
Something wrong with my WIFI, I can only see the 2.4GHz. cannot see the 5g anywhere.
not in the UI and not @ /etc/config/wireless.
I try Regenerate Configuration - no success .
I will be glad for any help
Thanks alot !


#352

If you are using a SNAPSHOT release, then you are not using the drivers mentioned here. I think you will get more help if you open an specific thread, or file a bug at kaloz's site.


#353

Packages updated to commit 1db017c:

  1. Corrected received signal of 88W8997.

Quite similar to the previous one, but this time for the 88W8997-based devices (WRT1200AC, WRT1900AC, and WRT1900ACS). Files available at https://github.com/eduperez/mwlwifi_LEDE/releases/tag/1db017c.


#354

Added packages for 17.01.6 from latest commit at https://github.com/eduperez/mwlwifi_LEDE/releases/tag/1db017c.


#355

New release available:

  • Upgrade 88W8997 firmware to 8.4.0.48
  • Assigned BSSID for updated FW API of 88W8997
  • Corrected WMM parameters element
  • Change driver version to 10.3.8.0-20180906

It does not seem there is anything interesting to OpenWrt users...
Files available at https://github.com/eduperez/mwlwifi_LEDE/releases/tag/ec0adbf


#357

New release available:

  • Changed the way to destroy BA
  • Upgrade 88W8997 firmware to 8.4.0.49
  • Added LED control for 88W8997
  • Change driver version to 10.3.8.0-20180920

Files available at https://github.com/eduperez/mwlwifi_LEDE/releases/tag/4a98c2b.


#358

New release available:

  • Fixed hidden SSID problem of 88W8997

Files available at https://github.com/eduperez/mwlwifi_LEDE/releases/tag/acaec0a.


#359

Hi Guys ,

I have the 5 Ghz not broadcasting. Havent been using the router recently so I dont know when this started. I am not sure what is the issues . I am running

Firmware Version LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)
Kernel Version 4.4.92

Any suggestions ?

This is what i got when I enabled debug , and logread log/wtmp

Mon Sep 24 10:21:35 2018 daemon.notice hostapd: wlan0: interface state HT_SCAN->DFS
Mon Sep 24 10:21:35 2018 daemon.notice hostapd: wlan0: DFS-CAC-START freq=5500 chan=100 sec_chan=1, width=1, seg0=106, seg1=0, cac_time=60s
Mon Sep 24 10:21:35 2018 daemon.err hostapd: DFS start_dfs_cac() failed, -1
Mon Sep 24 10:21:35 2018 daemon.err hostapd: Interface initialization failed
Mon Sep 24 10:21:35 2018 daemon.notice hostapd: wlan0: interface state DFS->DISABLED
Mon Sep 24 10:21:35 2018 daemon.notice hostapd: wlan0: AP-DISABLED
Mon Sep 24 10:21:35 2018 daemon.notice hostapd: wlan0: interface state DISABLED->DISABLED
Mon Sep 24 10:21:35 2018 daemon.notice hostapd: wlan0: AP-DISABLED
Mon Sep 24 10:21:35 2018 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Mon Sep 24 10:21:35 2018 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Mon Sep 24 10:21:35 2018 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Mon Sep 24 10:21:35 2018 kern.debug kernel: [77755.030699] ieee80211 phy0: change: 0x60
Mon Sep 24 10:21:35 2018 kern.info kernel: [77755.060734] device wlan0 left promiscuous mode
Mon Sep 24 10:21:35 2018 kern.info kernel: [77755.065245] br-lan: port 2(wlan0) entered disabled state
Mon Sep 24 10:21:35 2018 kern.debug kernel: [77755.098739] ieee80211 phy0: change: 0x100
Mon Sep 24 10:21:35 2018 daemon.notice hostapd: ELOOP: remaining socket: sock=22 eloop_data=0xb6fdbef0 user_data=0 handler=0x356f8
Mon Sep 24 10:21:35 2018 daemon.notice netifd: radio0 (21214): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Mon Sep 24 10:21:35 2018 daemon.notice netifd: radio0 (21214): Command failed: Invalid argument
Mon Sep 24 10:21:35 2018 kern.debug kernel: [77755.250696] ieee80211 phy0: change: 0xffffffff
Mon Sep 24 10:21:35 2018 kern.info kernel: [77755.325779] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mon Sep 24 10:21:35 2018 kern.info kernel: [77755.354724] device wlan0 entered promiscuous mode


#360

Why are you running an old version? Did you install the updated deiver? What are the contents on the wireless config file?


#361

I havent saw the new versions . Now I do , but cannot seem to have it go thru , check below please:

root@LEDE:/tmp# wget https://github.com/eduperez/mwlwifi_LEDE/releases/download/acaec0a/kmod-mwlwifi_4.14.63+10.3.8.0-20180920-acaec0aa-1_arm_cortex-a9_vfpv3.ip
k
Downloading 'https://github.com/eduperez/mwlwifi_LEDE/releases/download/acaec0a/kmod-mwlwifi_4.14.63+10.3.8.0-20180920-acaec0aa-1_arm_cortex-a9_vfpv3.ipk'
Connecting to 192.30.255.113:443
Redirected to /91330593/2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20180925%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20180925T091446Z&X-Amz-Expires=300&X-Amz-Signature=294462f3a7de87443fd846e8f4df890ee6468d6b81304470c8e8ea40fc30e3da&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3Dkmod-mwlwifi_4.14.63%2B10.3.8.0-20180920-acaec0aa-1_arm_cortex-a9_vfpv3.ipk&response-content-type=application%2Foctet-stream on github-production-release-asset-2e65be.s3.amazonaws.com
Writing to '2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256'
2f330c00-beb6-11e8-9 100% |*******************************| 84968   0:00:00 ETA
Download completed (84968 bytes)
root@LEDE:/tmp# ls -l
-rw-r--r--    1 root     root         84968 Sep 25 09:14 2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256
-rw-r--r--    1 root     root             4 Sep 24 10:32 TZ
-rw-r--r--    1 root     root          1584 Dec 13  1969 board.json
-rw-r--r--    1 root     root           321 Sep 25 09:07 dhcp.leases
drwxr-xr-x    2 root     root            40 Sep 24 10:32 dnsmasq.d
drwxr-xr-x    3 root     root           100 Sep 24 10:32 etc
drwxr-xr-x    2 root     root            80 Sep 24 10:32 hosts
drwxr-xr-x    3 root     root            60 Sep 24 10:32 lib
drwxr-xr-x    2 root     root            60 Sep 24 10:32 lock
drwxr-xr-x    3 root     root           100 Sep 24 10:32 log
-rw-------    1 root     root         57469 Sep 24 10:47 luci-indexcache
drwxr-xr-x    2 root     root           380 Sep 24 10:47 luci-modulecache
drwxr-xr-x    2 root     root            40 Dec 13  1969 overlay
-rw-r--r--    1 root     root            32 Sep 24 10:32 resolv.conf
-rw-r--r--    1 root     root            91 Sep 24 10:32 resolv.conf.auto
drwxr-xr-x    6 root     root           380 Sep 24 10:48 run
drwxrwxrwt    2 root     root            40 Dec 13  1969 shm
drwxr-xr-x    2 root     root            80 Sep 24 10:47 state
drwxr-xr-x   10 root     root          1048 Apr 27 21:05 syscfg
drwxr-xr-x    2 root     root            80 Dec 13  1969 sysinfo
drwxr-xr-x    2 root     root            40 Sep 24 10:32 tmp
root@LEDE:/tmp# opkg install --force-downgrade 2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm\=AWS4-HMAC-SHA256 
Unknown package '2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256'.
Collected errors:
 * opkg_install_cmd: Cannot install package 2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256.
root@LEDE:/tmp# 

#363

contents of wireless config in both files :

######## /var/run/hostapd-phy1.conf #########

driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
country_code=US
ieee80211d=1
hw_mode=g
beacon_int=100
channel=11

ieee80211n=1
ht_coex=0
ht_capab=[LDPC][SHORT-GI-20][SHORT-GI-40][DSSS_CCK-40]

interface=wlan1
ctrl_interface=/var/run/hostapd
ap_isolate=1
disassoc_low_ack=1
preamble=1
wmm_enabled=1
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
wpa_passphrase=!Abood1985
auth_algs=1
wpa=3
wpa_pairwise=CCMP
ssid=Alakhras-5
bridge=br-lan
wpa_disable_eapol_key_retries=0
wpa_key_mgmt=WPA-PSK
okc=0
disable_pmksa_caching=1
bssid=00:25:9c:14:48:21

#############/var/run/hostapd-phy0.conf###########

driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
country_code=AU
ieee80211d=1
ieee80211h=1
hw_mode=a
beacon_int=100
channel=acs_survey

ieee80211n=1
ht_coex=0
ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][DSSS_CCK-40]
vht_oper_chwidth=1
vht_oper_centr_freq_seg0_idx=-6
ieee80211ac=1
vht_capab=[RXLDPC][SHORT-GI-80][SU-BEAMFORMER][SU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][MAX-A-MPDU-LEN-EXP7]

interface=wlan0
ctrl_interface=/var/run/hostapd
ap_isolate=1
disassoc_low_ack=1
preamble=1
wmm_enabled=0
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
wpa_passphrase=!Abood1985
auth_algs=1
wpa=3
wpa_pairwise=CCMP
ssid=Alakhras-5
bridge=br-lan
wpa_disable_eapol_key_retries=0
wpa_key_mgmt=WPA-PSK
okc=0
disable_pmksa_caching=1
bssid=5a:ef:68:b7:0f:7e


#364

2 different country codes and setting auto channel on the 5ghz are your main issues.
PS. Typically people are looking for the contents of /etc/config/wireless, not your hostapd conf files.


#365

There aren't packages from 17.01.4 for version 10.3.8.0-20180920-acaec0a; you should either update to 17.01.6 first, or install packages from version 10.3.8.0-20180615-f5869c0.

And please, post your /etc/config/wireless file.


#366

I will upgrade the LEDE to 17.0.1.6 and upgrade the driver then see . config per below

BusyBox v1.25.1 () built-in shell (ash)

 _________
/        /\      _    ___ ___  ___

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
option htmode 'VHT80'
option channel 'auto'
option country 'AU'
option log_level '2'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option macaddr '5a:ef:68:b7:0f:7e'
option encryption 'psk-mixed'
option ssid 'Alakhras-5'
option wmm '0'
option key '!Abood1985'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
option htmode 'HT20'
option country 'US'

config wifi-iface
option device 'radio1'
option mode 'ap'
option ssid 'Alakhras-5'
option network 'lan'
option encryption 'psk-mixed'
option key '!Abood1985'


#367

upgraded lede to 17.1.6 , same issue with the package while installing :slight_smile:

root@LEDE:/tmp# wget https://github.com/eduperez/mwlwifi_LEDE/releases/download/acaec0a/kmod-mwlwifi_4.14.63+10.3.8.0-20180920-acaec0aa-1_arm_cortex-a9_vfpv3.ip
k
Downloading 'https://github.com/eduperez/mwlwifi_LEDE/releases/download/acaec0a/kmod-mwlwifi_4.14.63+10.3.8.0-20180920-acaec0aa-1_arm_cortex-a9_vfpv3.ipk'
Connecting to 192.30.255.113:443
Redirected to /91330593/2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20180925%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20180925T091446Z&X-Amz-Expires=300&X-Amz-Signature=294462f3a7de87443fd846e8f4df890ee6468d6b81304470c8e8ea40fc30e3da&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3Dkmod-mwlwifi_4.14.63%2B10.3.8.0-20180920-acaec0aa-1_arm_cortex-a9_vfpv3.ipk&response-content-type=application%2Foctet-stream on github-production-release-asset-2e65be.s3.amazonaws.com
Writing to '2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256'
2f330c00-beb6-11e8-9 100% |*******************************| 84968   0:00:00 ETA
Download completed (84968 bytes)
root@LEDE:/tmp# ls -l
-rw-r--r--    1 root     root         84968 Sep 25 09:14 2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256
-rw-r--r--    1 root     root             4 Sep 24 10:32 TZ
-rw-r--r--    1 root     root          1584 Dec 13  1969 board.json
-rw-r--r--    1 root     root           321 Sep 25 09:07 dhcp.leases
drwxr-xr-x    2 root     root            40 Sep 24 10:32 dnsmasq.d
drwxr-xr-x    3 root     root           100 Sep 24 10:32 etc
drwxr-xr-x    2 root     root            80 Sep 24 10:32 hosts
drwxr-xr-x    3 root     root            60 Sep 24 10:32 lib
drwxr-xr-x    2 root     root            60 Sep 24 10:32 lock
drwxr-xr-x    3 root     root           100 Sep 24 10:32 log
-rw-------    1 root     root         57469 Sep 24 10:47 luci-indexcache
drwxr-xr-x    2 root     root           380 Sep 24 10:47 luci-modulecache
drwxr-xr-x    2 root     root            40 Dec 13  1969 overlay
-rw-r--r--    1 root     root            32 Sep 24 10:32 resolv.conf
-rw-r--r--    1 root     root            91 Sep 24 10:32 resolv.conf.auto
drwxr-xr-x    6 root     root           380 Sep 24 10:48 run
drwxrwxrwt    2 root     root            40 Dec 13  1969 shm
drwxr-xr-x    2 root     root            80 Sep 24 10:47 state
drwxr-xr-x   10 root     root          1048 Apr 27 21:05 syscfg
drwxr-xr-x    2 root     root            80 Dec 13  1969 sysinfo
drwxr-xr-x    2 root     root            40 Sep 24 10:32 tmp
root@LEDE:/tmp# opkg install --force-downgrade 2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm\=AWS4-HMAC-SHA256 
Unknown package '2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256'.
Collected errors:
 * opkg_install_cmd: Cannot install package 2f330c00-beb6-11e8-904d-0921945f4e29?X-Amz-Algorithm=AWS4-HMAC-SHA256.
root@LEDE:/tmp# 

#368

Try to rename the file back to "kmod-mwlwifi_4.14.63+10.3.8.0-20180920-acaec0aa-1_arm_cortex-a9_vfpv3.ipk" before installing it. However, that is very unlikely to fix your issue; I would also try to avoid setting the channel to "auto", and would not specifying any country (or at least, do not specify a different country for each radio).