Pre-compiled updated mwlwifi drivers for stable releases


#369

Yer another boring release:

  • Changed slot time if needed for 88W8997

Files available at 10.3.8.0-20180920-34db09e.


#370

Thanks for these. Sorry for the noobish question... I'm interested in including these in my builds but it appears these are based on a kernel 4.14.63 but my snapshot is 4.14.71; is it okay just to drop mwlwifi.ko into 4.14.71? Is that a downgrade or an upgrade and will this cause issues because it seems these were meant for kernel 4.14.63?

Thank you for your advice:)


#371

Don't even try that... Instead, you should edit the Makefile for mwlwifi in your build, and point it to the latest commit at GiHub.


#372

exactly now am getting this , who this is done ?

root@LEDE:/tmp# opkg install --force-downgrade kmod-mwlwifi_4.14.63+10.3.8.0-20180920-acaec0aa-1_arm_cortex-a9_vfpv3.ipk
Upgrading kmod-mwlwifi on root from 4.4.153+10.3.4.0.git-2017-06-06-1 to 4.14.63+10.3.8.0-20180920-acaec0aa-1...
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-mwlwifi:
  •  kernel (= 4.14.63-1-c0354e0486370ffeacebcc4352595371) * 
    
  • opkg_install_cmd: Cannot install package kmod-mwlwifi.
    root@LEDE:/tmp#

#373

I think I got what you mean using the other build
root@LEDE:/tmp# wget https://github.com/eduperez/mwlwifi_LEDE/releases/download/34db09e/kmod-mwlwifi_4.4.153+10.3.8.0-20180920-34db09e-1_arm_cortex-a9_vfpv3.ipk
Downloading 'https://github.com/eduperez/mwlwifi_LEDE/releases/download/34db09e/kmod-mwlwifi_4.4.153+10.3.8.0-20180920-34db09e-1_arm_cortex-a9_vfpv3.ipk'
Connecting to 192.30.255.112:443
Redirected to /91330593/30777800-c1d9-11e8-8fb1-6c430ea73368?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20180927%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20180927T090105Z&X-Amz-Expires=300&X-Amz-Signature=45d6afb0d918162b10327137990e554ecca14fb94e2c42e84c9c9a319c51b194&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3Dkmod-mwlwifi_4.4.153%2B10.3.8.0-20180920-34db09e-1_arm_cortex-a9_vfpv3.ipk&response-content-type=application%2Foctet-stream on github-production-release-asset-2e65be.s3.amazonaws.com
Writing to '30777800-c1d9-11e8-8fb1-6c430ea73368?X-Amz-Algorithm=AWS4-HMAC-SHA256'
30777800-c1d9-11e8-8 100% |*******************************| 826k 0:00:00 ETA
Download completed (846334 bytes)
root@LEDE:/tmp# mv 30777800-c1d9-11e8-8fb1-6c430ea73368?X-Amz-Algorithm=AWS4-HMAC-SHA256 /tmp/kmod-mwlwifi_4.4.153+10.3.8.0-20180920-34db09e-1_arm_cortex-a9_vfpv3.ipk
root@LEDE:/tmp# opkg install --force-downgrade kmod-mwlwifi_4.4.153+10.3.8.0-20180920-34db09e-1_arm_cortex-a9_vfpv3.ipk
Upgrading kmod-mwlwifi on root from 4.4.153+10.3.4.0.git-2017-06-06-1 to 4.4.153+10.3.8.0-20180920-34db09e-1...
Configuring kmod-mwlwifi.
root@LEDE:/tmp#


#374

before the upgrade it worked by itself lol. After the upgrade its not working , and syaing disabled or unassociated :

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
option htmode 'VHT80'
option country 'AU'
option log_level '2'
option channel '108'
option txpower '20'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
option htmode 'HT20'
option country 'AU'

config wifi-iface
option device 'radio1'
option mode 'ap'
option ssid 'Alakhras-5'
option network 'lan'
option encryption 'psk-mixed'
option key '!Abood1985'

config wifi-iface
option device 'radio0'
option mode 'ap'
option network 'lan'
option encryption 'psk-mixed'
option key '!Abood1985'
option ssid 'Alakhras-5'

I dont know whats up.. how can I dig more into logs of this


#375

its working now! :slight_smile: by itself looks like it needed time and a reboot


#376

Lol, yea, still learning... I looked into it and my make file reports it is compiling latest.

Cheers


#377

You're still using DFS which means the radio won't fire up for at least 60 seconds. Which is probably why you thought it wasn't working at first.
You're making your own life hard. I'm glad its working for you, but when debugging just try the simple options first.


#378

Thanks , What is dfs and how am using it ? Let me know what i can do to enhance the experience


#379

https://openwrt.org/docs/guide-user/network/wifi/basic#dfsradar_detection


#380

More improvements for the 88W8997 chip that none of us owns:

  • Upgrade 88W8997 firmware to 8.4.0.51
  • Change driver version to 10.3.8.0-20181008

Files available at https://github.com/eduperez/mwlwifi_LEDE/releases/tag/3520811.


#381

Haha, another boring update. :stuck_out_tongue:

Thanks for the files @eduperez ! :slight_smile:


#382

Is it just me or do others also notice degraded performance with this version?


#383

I haven't done any extensive testings related too speeds, I just know it works for all my devices and use cases. The changes that kaloz has been publishing should only affect devices with the 88W8997 chip. But I will make speed tests now and share the results here.


#384

Using an Android phone, I can max out my internet connection at 100Mbps, and using iperf I get 250 - 300 Mbps between the phone and a computer connected by wire to the router.


#386

Hey guys,

Quick question...

I compiled a fw 5 days ago, which is 18.0.x, can I re-compile wifi driver using a source commit back from June? Or would I run into issues because back in June we were running ver 17.x.x

BTW, how can I tell what exact version of OpenWRT I have compiled? I did so from Master only 5 days ago so im guessing and wifi driver source from after ver 18.x.x should be okay?
/etc/version, etc/release, etc/os didn't contain any helpful hints...


#387

I'm away from that particular router for a while, but I should have been more specific -- looks like the range has degraded with that version at least in my use case. Anyways, as it doesn't seem to be a wide-spread issue, I conclude it's my specific device and not the new firmware. Thanks (as always) for keeping us up-to-date with the recent radio developments.


#388

What version number is displayed on the banner when you login?


#389

I can also write about my particular use case, obviously that does not mean it must work for everybody else.

A reduction in the range seems a bit strange... have you checked if there are more networks in you neighborhood now?