PPTP server on LEDE router WRT3200ACM

Hi guys
Firstly, I'm very sorry if my question is noob-like.
I have a Linksys WRT3200ACM with LEDE SNAPSHOT r6565-fd588dbf6b / LuCI Master (git-18.088.49307-90ed423).
How can I install PPTP server on it?
I tryed this howto - useless (no connect to router both inside or outside my LAN). If it is important - my ISP link uses PPPOE.

Great thanks for your advices!

P.S. Of course, I know that PPTP protocol is old and potential dangerous, but I must use it, no way.

I have it like this

root@home:~# cat /etc/config/pptpd
config service 'pptpd'
        option 'enabled' '1'
        option 'localip' '192.168.123.'
        option 'remoteip' ''

config 'login'
        option 'username' 'user'
        option 'password' 'password'

cat /etc/ppp/options.pptpd
name "pptp-server"
lcp-echo-failure 3
lcp-echo-interval 60
mtu 1482
mru 1482

make sure the firewall port is open, the remoteip should not collide with the client subnet, not all firewall allow pptp


Thanks, friend.
I tried but when I start pptpd /etc/init.d/pptpd start I see an error "sh: out of range"

My DHCP range is
in /etc/config/pptpd I set
option 'localip' '192.168.42.'
option 'remoteip' ''

What can be wrong?


cat /etc/pptpd.conf
speed 115200
stimeout 10
#localip & remoteip are not needed, ip management is done by pppd

do you have something else ?

No, nothing more
I tried to add localip and remoteip parameters - no result.

I googled the same case Default config file for pptpd lacks logwtmp option
Is it mean poptop package is buggy?

sorry I didn't see the mistake in my config, the local ip should be your router or a free ip, the error is shown, but if you run netstat -aptn you should see tcp 0 0* LISTEN 13044/pptpd
and in logread

daemon.info pptpd[13044]: MGR: Maximum of 100 connections reduced to 6, not enough IP addresses given
daemon.info pptpd[13044]: MGR: Manager process started
daemon.info pptpd[13044]: MGR: Maximum of 6 connections available

Thanks for everyone, problem solved due to softethervpn