Plugging in an unmanaged switch causes no internet situation - diagnostics can’t ping

I have two different unmanaged switches and when I plug either one in I lose my internet immediately. Routing just stops. I can’t reach internal devices I used to. I have no idea where to go, as I thought it was the switch and got another for testing purposes.

I’ve only ever used Luci so I’ve no idea how to pull the running config.

Can you draw a diagram of how things are connected (a photo of a sketch on paper is sufficient).

Do you have any VLANs configured on your router?

An unmanaged switch would be transparent to the network (unless it's broken, e.g. years ago, one of mine was reflecting packets when it was unpowered, which resulted in similar behaviour), so connecting it (as long as you avoid network loops!) shouldn't have any negative effect (and the router wouldn't even know about it).

1 Like

More background: I already have an unmanaged switch plugged in- this one seems to work without issues.

A second unmanaged switch had been plugged in and working fine until yesterday when I suddenly couldn’t ping or access the internet. Removing that switch “solved” the issue.

I bought a new, unmanaged switch and plugged it in- hey these things go bad. As soon as it was plugged in it also caused the same behavior- can’t ping OpenWRT in diagnostics and can’t route to internet/ pull up a web page. I’m at a loss here

Edit: I made no configuration changes when things stopped working which is why this is so wild to me

No vlans on this network

So the switch is connected to port 3? What is connected to the other ports on the switch? If you only have one connection to the switch (I.e just the router, nothing else), does the problem occur?

Here’s the confusing part I didn’t mention. I already had an unmanaged switch on one of the OpenWRT device ports working fine (4 total ports plus a wan port). A second unmanaged switch that WAS working on port 3 just stopped working. And it took the internet part of routing with it. I unplugged it and the problem disappeared. I replaced that second unmanaged switch on port 3 thinking it just went bad since it was a cheap one. Same behavior out of the box with a new one.

Alternately I tried plugging everything into the new 8 port switch just for kicks with only the wan plugged into my OpenWRT device along with the switch that now had all the Ethernet connections. That failed. I’m going device by device to see if something is causing this.

Plug one thing in at a time. Watch for when the problem manifests. Then unplug the last thing. It is possible that you have a switching loop which will absolutely take the network down. But there are other things that could cause this.

Some devices can misbehave in very unexpected ways... for example, I've seen:

  • USB-C docking hubs with ethernet that have a bug that will flood the network with broadcast packets when the host computer is disconnected or sleeping
  • Peloton bikes that have bridged ethernet and wifi inerfaces... if both wifi and ethernet are connected, that causes a switching loop and the network dies.
  • Sonos with more than one device hardwired can screw things up if their STP algorithm fails.
  • and more...

Ok I may have located the problem and this is the only thing that changed. My wife told me she got a new docking station from work- brand new Dell thunderbolt 4 dock. It’s making one of those bum power supply noises inside as I get close to it. I had no idea she swapped it out and I was just looking at the wiring closet since the cable never changed.

I thought I was losing my marbles, unmanaged switches don’t mean diddly to the topology they just pass stuff along. I’m gonna have her take that hunk of junk back to work tomorrow and get another.

Glad you found it.... and yes, another example of unusual or unexpected failures.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Thanks to all of you for talking this out with me- the suggestion on wayward devices came through right as I was checking individual cables.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.