Please Help with meraki mx60w, accidentally the whole thing

Hi, I was trying to get lede working on the mx60w, and the network was refusing to work with all the different versions I tried 17.0.1 to .4 and the dev builds, but network would never come up right, I got so frustrated I accidentally deleted the board-config ubi partition..
does anyone have a copy of this or could point me in a direction on how to get it back? or... help me in some way? :expressionless: thanks!

Anything at helpful?

Hi thanks for the reply,
That site is essentially where I followed since the beginning, I followed his guide to a T the first time, but then it didn't work, so I got into the uboot and booted the init bin file, and that worked fine, then ran all the commands he said, which was fine, but I couldn't download image to it because network wasn't working, not entirely sure why, then I tried a few other versions of the init bin. none of which network worked. at this point, I found a thread with a few people with the same issue, and no solution. so I ended up removing the vlans and the bridge from the config and restarted network, then network was working, then logged into the lede gui and tried to flash the thing but it said invalid or unsupported image blabla for the 17.01.4, at this point i'm getting mad, so then I went into the cli, downloaded the image with wget, and did sysupgrade on it. still refused to work, couldn't create rootfs or some garbage. then I tried to use the gui to flash the latest snapshot. that... actually accepted and flashed, but the whole thing was super broken after that, the lan ports wouldn't even light up anymore or anything. so then I tried to reflash older ones and didn't work, and ended up deleting the ubi0 board-config and now i'm stuck I don't even know what to do anymore. I even tried riptide's original releases, those wouldn't even boot the initrs image..

1 Like

You're probably looking at a serial or JTAG flash.

Hi jwoodz, thanks for the opinion, I already have serial connected as that's how I was doing it in the first place , and it still boots the init image its just I don't know what to do with itnow, and and I don't know the significance of the board-config partition That I deleted and that all the guides say in bold not to delete...

You might post on the Cisco forum to see if someone can get you a copy of the original ubi0 partition.

There are other resources you might look in to...

Unfortunately, it's a hard lesson to learn.

hey . i am also facing same network issues. can you help me
if possible can you send me the file with working network connection

@alphaz18's router is currently hard-bricked.

not exactly hard bricked as i can boot to lede from the tftp image on the uboot, i'm just missing a partition that i dont know what purpose it serves.. sealghost, do you think you can make me a copy of the board-config partition? i'm missing that partition because i accidentally deleted it, even though i have no idea what purpose it serves.

Likely the same for meraki...

thanks, i'll see if i can ever get to that point,
would you happen to know why i can't flash lede to it? the sysupgrade command seems to fail to create the rootfs partition, saying the partition make command can't have 0, its as if its using an incomplete or wrong command to do it.. :\

i can try to download the board config file but my network is not working. if you can explain me from where you removed the VLan and Bridge config details. i can connect to network and make copy of boardconfig file. Thank you

sure, so once you boot into the tftp image, you have the shell, then do
vi /etc/config/network
change lan from eth0.1 to eth0
change wan from eth0.2 to eth1
change wan6 from eth0.2 to eth1

then go to bottom and there is 3 seconds of switch0 stuff,
just delete all 3 switch/vlan sections, then save and exit vi,

after that type /etc/init.d/network restart
then you should be able to communicate through the network to the box

@alphaz18 thank you very much. network is working great. So please tell me how to download the board_config file. so that i can send you. i know it is in /dev/ubi0 -N board-config but when i tried to copy the file ,it isnt copying.

nice to hear! umm for copying the file.. i think you do "ubinfo /dev/ubi0 -N board-config" to determine which partition it is.. the partition id will be listed. then once you determine that, "dd if=/dev/ubi0_XX of=/tmp/board-config.img" where you replace XX with the partition id, so if partition id is 2 then do "dd if=/dev/ubi0_2 of=/tmp/board-config.img" then find a way to copy the newly created /tmp/board-config.img file somewhere so that you can post it? :slight_smile: thanks!

Once again thank you
here is your board_config file

thanks! much appreciated! now if only we can figure out how to flash the permanent image to it.. without the thing failing..

clearly i'm not a programmer, :\ though i have a software engineering degree lol...
but i got it working, super duper hacky, but i dont want to spend the energy deciphering all the scripts, so for me there was a bunch of different things going on, first if i boot to initramfs then do that stupid trick to get lan working, then go to the http gui, and click sysupgrade and give it the tar file, it fails saying not a valid image, which is really stupid to begin with. so then i went into the serial console, wget the tar image to /tmp, then tried sysupgrade with -F and it still failed saying could not create ubi partition with size 0... i dont know what the hell is going on there. so i went into /lib/upgrade/ then scrolled way down to where it was doing ubimkvol -N rootfs then if you look a few lines above that theres a condition for the size, either "-m" or "-s blabla" i changed the blabla variable to 16MiB , so that it can successfully get through that portion of the sysupgrade script, then it failed to find the image because apparently it was looking for mx60/root in the tar file whereas in my image its mx60w/root so i downloaded 7zip, opened the tar file, renamed the folder from mx60w to mx60 then wget again to the box. then now this time ran the sysupgrade -F -n -v /tmp/lede-blabla.tar worked! then once done, plug in the network to port one of the switch side and not the wan anymore, and .. suprisingly everything seems working! i didn't try the wireless yet though. but shrugs. thats enough nonsense for a week for me.

so recap:
step 1. follow most of this guide Up until step 7.
step 2. network broken so do fix above, ie delete switch and rename interfaces without vlan from /etc/config/network for the time being when booted from initramfs image. then restart network /etc/init.d/network restart
step 3. if you are on mx60w like me, open the sysupgrade.tar file in 7-zip and rename the mx60w folder to mx60. exit.
step 4. copy the modified tar from above into /tmp of the device using a http or whatever method you can do.
step 5. go edit /lib/upgrade/ scroll down to where it creates ubimkvol -N rootfs $sizewhatever , a few lines above theres an if statement saying that variable is either -m or "-s $1" replace the $1 or wahtever is there with 16MiB (i just randomly chose this number) since its larger than the image so "-s 16MiB" save the file. exit.
step 6. go to /tmp and run sysupgrade -F -n -v lede-blabla.tar
should reboot in a few seconds. then you're done.
step 7 plug in network to lan1 port now everything should work :expressionless:

hi. i have booted and upgraded all the firmware settings. but i can only see one interface eth0. what happened to other four interfaces. do you have any idea? and help me to activate other interfaces.. Thank you

so which steps did you do? were you able to do the sysupgrade successfully?