Please help me troubleshoot wireless repeater bridge configuration

Openwrt newbie here though have used dd-wrt on another router for a while before. I am trying to setup a wireless router repeater bridge to amplify a a wifi signal. My neighbor kindly shared his password while I wait for install appointment to enable me to teach from home. But the signal is weak except couple of spots. My plan is to sue a router in that spot to get the signal and make a local subnetwork distributing it.
I've set up the N600 with openwrt and used the following guide:

Got both network to setup but no internet when connected to subnetwork. I am not sure where to go from here in terms of troubleshooting? Is it a config issue? is the wifi coming to the router is nto stron enough? Anything else? Screenshot of wifi config from a browser attached.

Install travelmate package. It does exactly what you need.

Ok, doing my best here. But between the unstable internet connection and need to switch between the two networks, I can't figure out how to make that travelmate to work/showup.

My current version is:
Powered by LuCI openwrt-19.07 branch (git-20.057.55219-13dd17f) / OpenWrt 19.07.2 r10947-65030d81f3

I was able to install travelmate successfully but have no idea how to access its interface. Trying to installl luci-app-travelmate does not work wtih the following error:
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-travelmate:
  • luci-compat
  • opkg_install_cmd: Cannot install package luci-app-travelmate.

Attempt to install luci-compat fails with the following errror:
Installing luci-compat (git-20.086.76556-9edb933-1) to root...
Collected errors:

  • check_data_file_clashes: Package luci-compat wants to install file /usr/lib/lua/luci/tools/webadmin.lua
    But that file is already provided by package * luci-base
  • opkg_install_cmd: Cannot install package luci-compat.
    The opkg install command failed with code 255

I've tried to unistall luci-base but that was a bod idea, had to do router reset to get back to virgin config.

I am all for reading the manual but this is really beyond me and my internet connection to solve this. Community help would be really appreciated.

Run this: opkg install --force-overwrite luci-compat and then try again with travelmate.
The luci package also has a wizard which should make your life setting it up quite easy.

Thanks again. I do appreciate your time! But I am not sure how to run these command. I was using web interface to upload install and there is no option there to customize opkg execution. I downloaded putty to ssh but not sure how to get the file onto the router. Getting Failed to download, package not available... error.

When you connect to ssh, first update the package list: opkg update
Then fix the luci issue with opkg install --force-overwrite luci-compat
Finally install travelmate opkg install luci-app-travelmate

I think opkg update needs router to be online, connect to the internet.
But it is not. Getting Failed to download, check network settings... Error

That is the issue I am trying to solve. Catch 22?

Yes it requires internet to download the packages, or you could download them (and the dependencies) in another system and copy them with SCP to the router.

It will be easier to create the wireless client only, as you showed in the first post, without enabling the access point. After you manage to connect to your neighbournet, install travelmate and continue from there the finalizing of the access point.

your problem is the lan gateway, change it in interface,lan.

The LAN and WAN IP ranges cannot overlap. If the ISP network (your neighbor) is using IP's in the commonly used (and OpenWrt's default) 192.168.1.X range you need to change your router's LAN to an IP that is not in that range, such as

On the main status page you should see that an upstream network has been set up, which means that it has made a connection to your neighbor. Then confirm that the IP does not conflict.

Thanks all for help. Eventually was able to make it work with travelmate. It was notIP issue as I changed ip to first step. Not sure why it did not work with my manual setup but once I was able to figure out how transfer the files, it worked.

1 Like

If the problem is solved, feel free to mark the topic accordingly .