Password issue with r7800

I lost/forgot my Openwrt root pw and asked about this a few months ago, but procrastinated. Got good info including: use the failsafe mode and Resetting the root password. But I'm not sure about how to get into failsafe mode with my r7800. Can I do it thru my existing LAN Ethernet connection? I can ping the router with $ ping Or do I need a different (maybe usb) connection?

Also, reading about rebooting the 7800 into failsafe mode, should I turn it off then on and hit the recessed reset button (at a certain point) as the failsafe note says. I'm worried about bricking the install (which has been working great).

You can enter it just by pushing a button on a 2 second long time window during boot. Read the advice from wiki.

One easy way is to push the WiFi button every second during the boot, until the power led starts blinking really rapidly (which indicates that you entered the failsafe mode.)

Then the router has IP and you need to set your pc to something like and use normal ssh terminal to connect to it via LAN.

Luci is not enabled, so you need to do everything from ssh console.

I did read the note, and your comment is helpful, but I'm wondering if the button on the r7800 is the recessed "reset" one. I'm guessing so, but there is another button (not recessed) that seems to start the reboot I'm a bit confused.

Also when setting up Openwrt (2 years ago), I did use ssh to do some things with Luci, but have forgotten that process. How to enable the ssh connection exactly? Sorry, for the need for detail...your basic answer was fine. thx, feffer

On my R7800 there are three buttons...

  • On back panel the recessed reset pinhole
  • on top right the wifi button/LED combination (second LED from right)
  • on top right the WPS button/LED combination (rightmost LED)

Thatswhy I said "wifi button" above. It should work just fine.

Regarding basic SSH terminal, you are pretty much on your own.
(I use the "putty" terminal software in Windows, but there are lots of alternatives)

Do you mean the physical power button on back left????
That is just a normal power button.

In addition R7800 backpanel has the physical slide switch for LED control (turning off most LEDs), but it does nothing else to my knowledge

1 Like

Thx for the help with the buttons. Pretty sure I was able to get into failsafe mode. The far left LED was blinking very fast. I manually changed my computer's IPv4 address and was able to ping the router at

Unfortunately I've been unable to ssh into the router. My ssh config is mostly public/private key sets. That leads to a failure to verify. Tried turning those off, but everything I try finally leads to a request for a password...and then failure. I never get to the place where I can issue the "# mount_root" command. When I've tried, I get, "command not found."

I tried simplifying, by disconnecting everything except the ethernet to PC cable...but no joy. Not sure how to proceed.

OK, I got it. Basically, hnyman laid it out well, but I was trying $ ssh and this was failing at the authentication stage. After a lot of searching, I tried, $ ssh root@ and this opened up the dialog

root@(none):~# mount_root
switching to jffs2 overlay
root@(none):/rom/root# passwd
Changing password for root
New password:
Retype password:
passwd: password for root changed by root
root@(none):/rom/root# reboot -f

I was able to reset the OpenWRT pw successfully after that. Thank you

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.