Passwall lite can't install

I am getting error below while trying to install passwall lite

Description

LuCI support for PassWall

  • Required dependency package libopenssl3 is not available in any repository.
  • Required dependency package sing-box is not available in any repository.
  • Required dependency package tuic-client is not available in any repository.
  • Required dependency package luci-lua-runtime is not available in any repository.

What do you see from this:

ubus call system board

ubus call system board
{
"kernel": "5.10.111",
"hostname": "OpenWrt",
"system": "MediaTek MT7621 ver:1 eco:3",
"model": "TP-Link Archer C6 v3",
"board_name": "tplink,archer-c6-v3",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "22.03.0-rc1",
"revision": "r19302-df622768da",
"target": "ramips/mt7621",
"description": "OpenWrt 22.03.0-rc1 r19302-df622768da"
}
}

I am using this old build because with latest stable my passwall lite version doesn't work.

I have also added these line in file: /etc/opkg/customfeeds.conf

src/gz kiddin9_core https://op.supes.top/packages-23.05/mipsel_24kc
src/gz kiddin9_base https://op.supes.top/packages-23.05/mipsel_24kc/base
src/gz kiddin9_luci https://op.supes.top/packages-23.05/mipsel_24kc/luci
src/gz kiddin9_packages https://op.supes.top/packages-23.05/mipsel_24kc/packages
src/gz kiddin9_routing https://op.supes.top/packages-23.05/mipsel_24kc/routing

Last error i was having this

LuCI support for PassWall Required dependency package tuic-client is not available in any repository.

Two things come to mind here:

  1. you are using 22.03 yet you have feeds for 23.05. That is almost certainly not going to work as the packages for 23.05 will probably not be backwards compatible.
  2. You'll have to reach out to the maintainer of these packages to get help since they are not coming from the OpenWrt repo.
1 Like

Yeah it seems they had deleted the old repo. This is why i can't use it anymore because after installing it will break my router.
Anyway Thanks i will contact them.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

Well i can keep it unsolved as long as real issue has been solved. Meanwhile others can post here and also get some help.

I guess, but there is really nothing that we (the OpenWrt community) can do to resolve your issue because it is a problem with another site and the packages they (previously) hosted.

You cannot install windows office either. As strange as it might sound. Neither is supplied by OpenWRT.

Probably 2 years was enough to test OpenWRT prerelease and you are welcome to sysupgrade to supported one.
https://firmware-selector.openwrt.org/?version=23.05.3&target=ramips%2Fmt7621&id=tplink_archer-c6-v3

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.