Partial loss of connectivity to raspberry pi devices

This is a strange one I've started to run into recently with 3 of my Raspberry Pi devices. The Raspberry Pi's (2x pi4 1x pi3) are connected to my network via the built in wifi.

I can always ping the devices from my router, but I can only ping them some of the time from my laptop. Here's an example:

$ ping -c 1 backup0.lan
PING backup0.lan ( 56 data bytes

--- backup0.lan ping statistics ---
1 packets transmitted, 0 packets received, 100.0% packet loss

$ ssh root@ ping -c 1 backup0.lan
PING backup0.lan ( 56 data bytes
64 bytes from seq=0 ttl=64 time=3.823 ms

--- backup0.lan ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 3.823/3.823/3.823 ms

I have nothing fancy in my network configuration other than enabling QoS/SQM.

If I wait long enough, the raspberry pi will become accessible and I'll be able to connect to it for a period of time without any issues. Then, out of the blue connectivity is gone and I have to proxy everything through the OpenWRT router!

Any ideas where I should start looking to resolve this?

An additional piece of information, I logged into my Raspberry Pi console, pinged my laptop, and then my laptop was suddenly able to ping my Raspberry Pi.

Is it the same if you ping more than one time?
Maybe it is in some power save/sleep mode and delays to answer the first packet.
Also if there is no arp entry, it will take some time to fill that in too.

Yeah, same if I ping one time or 100 times.

Why/how would the arp entry be a problem?

When there is problem, check the arp table of the laptop.
Are there entries for the raspberries? If yes, check on the raspberry if the ping is received (with tcpdump) and if there is a reply.
If not, start a ping. Are there entries now? Check with tcpdump if the arp requests are being propagated and replied by the raspberries.

Is your main router a WRT3200 or WRT1900 or any of those mvebu devices?

In my experience this kind of thing is one of the problems I had with those mvebu devices and goes away as soon as you trash those in favor of something that works.

I'm using a Netgear R7800. I already learned the hard way to avoid the WRT3200!

1 Like

This is a power management issue on RPi.

Here is how to fix it:

1 Like

@peternikolow thank you. I've disabled power power saving mode on the adapter and will report back here what happens.

This may also explain another issue I was having. I'm using these Raspberry Pi's to copy zfs snapshots off my primary device for backup purposes and network performance is frequently poor. It may be that the power saving mode is also throttling the transfers.

This may be related to poor RPi Wifi internal antena.

Because of that issues i've using RPi only to Ethernet.
Wifi is great on first sight... but using in real life make only headaches.

So far so good on disabling the power saving feature. Every time I've checked I've had connectivity. I'm also not worried power usage as I only plug these devices in when syncing backups anyway, they are turned off 99% of the time.

Appreciate the help everybody!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.