Packet loss and Latency R7800



I concur.

Sure it does. For every packet dropped on the floor, equals approximately another packet that has to be resent from the far end. This becomes worse if the traffic were UDP, for example - as it's stateless.

I think the OP needs more bandwidth...I'm trying to imagine how there's even enough upload bandwidth if, for example, he and his son were gaming with audio and/or video enabled.

1 Like

I basically agree with you, but if video is not enabled, you should be able to run 2 game streams and 2 VoIP streams on 2Mbps upload... But just barely... If you have say 6-10Mbps upload you will be much more comfortable.


That (good) hypothesis is easy to test, install (@snoop I am talking to you here, not @lleachii :wink: ) iftop on the router (opkg update ; opkg install iftop) and rund it against the the wan interface (to test this look at the l3_device otr the device reported from ifstatus wan) by issueing iftop -i $MYWANINTERFACE, obviously replace $MYWANINTERFACE by the result from the ifstatus query....

That should allow you to monitor the network load generated by one or two of the connected devices to figure out whether the upload is the limit. As a rule of thumb a VoIP-quality voice channel requires around 100Kbps, video will require more....


Games seem to vary as well, from maybe 250kbps to 600+... Two games and two VoIP streams could be 1400kbps, and then bursts of game activity might go into the 2000 range, so it could be tight.


OK I installed it.

  1. Turn on SSH to wan or lan?
  2. I'm installing CMDer.
  3. Connect to Router.
  4. Issue a cmd iftop -i $MYWANINTERFACE
    Am I missing a step?
    My Modem is a arris CM8200A
BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt 18.06.2, r7676-cddd7b4c77
root@OpenWrt:~# iftop -i $MYWANINTERFACE
iftop: unknown option -i
iftop: display bandwidth usage on an interface by host

Synopsis: iftop -h | [-npblNBP] [-i interface] [-f filter code]
                               [-F net/mask] [-G net6/mask6]

   -h                  display this message
   -n                  don't do hostname lookups
   -N                  don't convert port numbers to services
   -p                  run in promiscuous mode (show traffic between other
                       hosts on the same network segment)
   -b                  don't display a bar graph of traffic
   -B                  display bandwidth in bytes
   -a                  display bandwidth in packets
   -i interface        listen on named interface
   -f filter code      use filter code to select packets to count
                       (default: none, but only IP packets are counted)
   -F net/mask         show traffic flows in/out of IPv4 network
   -G net6/mask6       show traffic flows in/out of IPv6 network
   -l                  display and count link-local IPv6 traffic (default: off)
   -P                  show ports as well as hosts
   -m limit            sets the upper limit for the bandwidth scale
   -c config file      specifies an alternative configuration file
   -t                  use text interface without ncurses

   Sorting orders:
   -o 2s                Sort by first column (2s traffic average)
   -o 10s               Sort by second column (10s traffic average) [default]
   -o 40s               Sort by third column (40s traffic average)
   -o source            Sort by source address
   -o destination       Sort by destination address

   The following options are only available in combination with -t
   -s num              print one single text output afer num seconds, then quit
   -L num              number of lines to print

iftop, version 1.0pre4
copyright (c) 2002 Paul Warren <> and contributors

I hope I did it right... It's a lot to take in right now. 8 hours sleep 3 days oh boy... LOL

You need to replace $MYWANINTERFACE with your real WAN interface name. eth0 ?

Got it eth0 is the name..

I tried connecting with wan but it won’t let me. Do I need to be plugged into the wan port or the lan port on back of router?

It keeps saying connect refused when I use interface wan. It works with interface lan.

You ssh from the LAN side into a LAN port. ifconfig will list all your network interfaces and there will be one with your external IP. You use that name in iftop. If you are using DHCP, it will be eth0 or eth0.2 or similar. If PPPoE, then it is pppoe-wan.

also @snoop, put the output of the commands between triple backticks, or select it and click the </> button to get preformatted text, it's the only way we can really reliably read the output.

Ok... one problem when trying to connect using (interface wan) port 22 connection refused but if I change it to lan it will work.

that's normal, connecting on WAN is like someone on the internet trying to connect to your router, it's firewalled off so they can't change your settings :wink:

My dear LORD do I need to get an xterminator here. A lot of ticking going on! Or do I need a tick collar. :joy:.

Your doing good!

Watching a few youtube video's on using ssh might help.... it is well worth the frustration when you see the realtime client per client traffic utilisation :slight_smile:

Do you know many people with the same ISP as you? Are they happy? Before hardware.... that would definitely be the next point of call.....

And, apologies for my previous post.... it was a little blunt.

So I’m in and connected with interface lan. But it definitely won’t let me connect with wan.

Now I see the l3 _device which is my wan eth0.2.
Is this the correct way to type in the info
iftop -i eth0.2?

Dam, did you guys jump ship :ship:. I feel all alone here. LoL

Yes, that's right, try that command

Ok it says error opening terminal window cygwin

Should I select interface wan and reboot router?

Every time I try wan it says connect to host port 22 connection refused

ignore connecting on WAN, you never want to connect on WAN... move on to the situation where you connect via SSH using a LAN port, and then run the command

iftop -i eth0.2

8200 or 820 ?

+1 yes that should work!

Arris 8200A