OpenWrt will not install on Mikrotik RB760igs, tried everything


since hours I'm trying to install openwrt on that damnet Mikrotik garbage :disappointed_relieved:

Mikrotik RB760igs

I'm using Windows 10 64bit

I tried it with tinyPXE and TFTPD but without any success. After hours of changing configurations, network cables, USB ethernet cards, ... I get the following now:
"Got IP address:"
"resolved mac address 00:50:B6:0A:B3:A8"
"**********************falling back to small packet size"
"**********************kernel loading failed"

Files I'm trying to use:

Current router settings:
o-e "boot device - boot over Ethernet"
p-1 "boot protocol - bootp protocol"
b-2 "booter options - force backup-booter loading"
but I tried all combinations of these three settings...

Any idea what could be the problem here?

@freddy, welcome to the commnity!

  • Do you have to enable TFTP on the MikroTik?
    • Did you do so?
  • Did you open the firewall on the Windows mahcine?

I don't see much instructions about the RB760igs offhand. I do see that you're trying to PXE network boot, but options 66 and 67 are not set. If it's doing a full PXE boot your DHCP server has to send option 66 to point the router at the TFTP server-- which in this case is also the Windows PC. Option 67 is probably also needed for the file name. Rename the initramfs to a short name and check the TFTP server to see if any file was requested.

Use initramfs for network boot then the sysupgrade is the second step to install.

First of all, thanks a lot for your tips!

I don't know why, just changed the bootloader settings arround, switched over to TFTPD again, changed back to the settings mentioned above. While the router was trying to connect I stopped TFTPD and started tinyPXE again and now it's working :see_no_evil:

Years ago I installed OpenWrt on several WRT54g and also on an Asus RT-N10U, never had lot of bad experiences but this thing drove me nearly crazy :grimacing:

Maybe anybody can give me a hint what's the meaning of that ***** the router shows, because now since it's working I get:
"transfer started ................................... transfer ok, time=3.72"

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

Here is what I did so far to get the router working

Uninstall personal firewall stuff and virus scanner, it's recommended to do this inside a virtual machine

Select correct files for RB760igs from OpenWrt page

Open device and solder serial terminal (e.g. use CH340 to USB module), this will save you a lot of time but you will lose warranty!

Press "x" on terminal to enter bootloader menu

enter p-1     = bootp
enter o-e     = boot from Ethernet (must be changed later!)
enter b-2     = force backup-bootloader loading
enter e-yes   = format storage (no fear, can be undone with Mikrotiks netinstall tool)

If you have problems with the network

try another cable
try another USB-Ethernet card

Set your network card to


Use TinyPXE

copy image "...initramfs..." into TinyPXE sub folder .../file/boot
select "HTTPd"
set Option 54 to
set IP Pool start to
set Next-Server to
set Option 1 to
set Option 3 to
set Option 6 to
set Option 28 to
enter the "...initramfs..." file into Filename text field
deselect "Filename if user-class=gPXE or iPXE"
select [Online]

Now let the router boot...

Router should boot with following message (or similar one)

RouterBOOT backup booter 6.46.3


CPU frequency: 880 MHz
Memory size: 256 MiB
Storage size:  16 MiB

Press any key within 2 seconds to enter setup..

loading kernel... kernel not found
trying bootp protocol.... OK
Got IP address:
resolved mac address 00:50:B6:0A:B3:A8
transfer started ................................... transfer ok, time=4.44s
setting up elf image... OK
jumping to kernel code
[    0.000000] Linux version 5.4.81 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r15151-13961da6ce)) #0 SMP Sun Dec 6 08:18:07 2020

Copy "...sysupgrade..." file to router via scp

scp -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null openwrt-ramips-mt7621-mikrotik_routerboard-760igs-squashfs-sysupgrade.bin root@

Write image into NAND flash now

sysupgrade -v /tmp/openwrt-ramips-mt7621-mikrotik_routerboard-760igs-squashfs-sysupgrade.bin

Connect the router's WAN port to your common router and reset it to get internet access

opkg update
opkg install luci-ssl
opkg install luci-i18n-base-<language>

Hope this helps anybody, otherwise please ignore it!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.