OpenWrt Wifi not found by cameras

Hi all,

I have got 2 cameras DLink and I have a router using openWRT.

When I install the app into my mobile to setup the cameras one step is to set the wifi that will use the cameras. Both of them can see all the wifi networks except the 2 from my openwrt router.

I have added temporally a wifi extender and the cameras can be setup but not with the openwrt router wifi.

Into the wireless interfaces I have MAC-Address Filter 'Disabled' so I do not know if I should do something with the firewall as my knowledge on openWRT is really basic.

If you need any further information please let me know.

Thank you very much

Quite a bit more info is necessary to understand what might be causing the issue:

What are the DLink camera models?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
2 Likes

Quite a few proprietary devices only see a subset of channels (e.g. no DFS channels or ch12/13) or have problems with less common configurations (802.11w, 802.11r, WPA2/ WPA3 mixed-mode, etc.).

1 Like

WPA2/WPA3 mixed mode seems to be problematic on certain devices, my Chromecast w/Google TV (4K version) doesn't support WPA3, and using mixed mode it couldn't fallback to WPA2. I believe there is bug in client side driver causing issue.

1 Like

If it is a new install of OpenWrt,
Did you enable both the wireless in the OpenWrt router?

Hi, thanks very much for your response,

The models of the cameras are dlink DCS 8000LHV2 and DCS 8515 LH, both of the does not see the openwrt router but they connect and works with another network.

here it is the cat of the config files.

network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd09:62ab:6906::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'
        option ifname 'eth0.1'

config interface 'wan'
        option username '794912563@digi'
        option proto 'pppoe'
        option password '3DLxcsuM'
        option ipv6 'auto'
        option ifname 'eth1.20'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth1.20'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '5t 3 2 1 0'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 4t'
        option vid '20'

Wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'ES'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr 'I have removed'
        option ssid 'LoveNet5G'
        option encryption 'psk2'
        option key '************'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option channel 'auto'
        option htmode 'HT40'
        option country 'ES'
        option noscan '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr 'I have removed'
        option wmm '0'
        option key '***********'
        option ssid 'LoveNet'
        option encryption 'psk2'

Firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Yes all my devices (chromecast, google nest, google home, bulbs, etc...) are connected and working with openwrt networks

since you're not showing the passwords, make sure they're "simple" (or at least start there, and work your way forward), some devices can't handle special chars very well.

you could also try HT20 instead of HT40.

set a low chan, < 12, as @slh mentioned, instead of auto.

2 Likes

I have removed the password to the network but still cannot see it. I think that may is some security rule because I access to the camera available wifis using a mobile app (mydlink) so may openwrt has one kind of policy around that and do not forward his wifis there, no idea to be honest.

I have set channel 5 and width 20 Mhz but still cannot find it, that wifi is 2.4

I assume your phone can find it, or any other device ?

1 Like

Yes more than 20 devices, laptops, google nest, chromecast, mobiles, etc... The router is a linksys WRT1900CS V2 and produces two wifis one is 2.4 and the other 5g and the cameras cannot see any of them but on the other hand can see all the rest even if I share wifi with my mobile.

@maoso, I wanted to be sure of the details provided by that output - before I responded with a suggestion(s).

Can you provide this output?

It seems to be missing.

1 Like

Yes here it is:

ubus call system board

{
        "kernel": "4.14.195",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 1 (v7l)",
        "model": "Linksys WRT1900ACS",
        "board_name": "linksys,shelby",
        "release": {
                "distribution": "OpenWrt",
                "version": "19.07.4",
                "revision": "r11208-ce6496d796",
                "target": "mvebu/cortexa9",
                "description": "OpenWrt 19.07.4 r11208-ce6496d796"
        }
}
1 Like

Thanks.

To be clear, is 5.4 GHz is OK now?

(Or there's only 2.4 GHz or something?)

Try: 1

:spiral_notepad: ( 0 is invalid in so many [modern] 2.4 GHz combinations of configs - it's better to leave it at the default of 1.)

not that i'll help here, but I'd upgrade to at least 19.07.10, but 19.07 is EOL.

1 Like

Hi Ileachii,

The wifis are ok so I work with both of them on multiples devices. The thing is that the cameras cannot see any of them, not 2.4 GHz neither 5.4 GHz, so both of them are not visible by the cameras when I try to setup them using a mobile app called myDlink,

going to try

I have done it, so I have set wmm with default value (activated) and still the same the camera cannot see the network.

Sadly mwlwifi is known to have interopetability issues, which aren't fixable (as Marvell/ NXP has abandoned it half a decade ago). By disabling WMM (which is 'wrong', as it reduces throughput to 54 MBit/s) you have already made this broken driver most compatible with IoT devices, so beyond that, there is probably no room for further improvement - apart from switching to non-mwlwifi wireless hardware.

P.S.: consider changing your PPPoE password.

1 Like

Thank you, I have reactivated it, I think that I have only deactivated to check this issue but on the 5g was activated (now in both) and the cameras can still not find the wifi networks,

could be something related with the firewall?
may the cameras cannot forward the wifi networks of openwrt to the mobile phone application? or may that have not sense.