OpenWrt support for WAX206

In case anyone wonders what /etc/fw_env.config would be, here it is:

# MTD device name   Device offset   Env. size   Flash sector size  Number of sectors
/dev/mtd3           0x0             0x2000      0x20000            1

And a simple VLAN (111) in router mode works fine for me with static IP & DHCP:

network config
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde8:72be:1c0b::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'br-lan.1'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '111'
	list ports 'lan1'

config interface 'VLAN111'
	option proto 'static'
	option device 'br-lan.111'
	option ipaddr '10.111.111.1'
	option netmask '255.255.255.0'
	option delegate '0'
1 Like

That does not mean I don't value your input :slight_smile:

I am pretty sure that you would love me to donate to the project instead if you don't do it for the bounty. I just wanted to make sure everyone involved was aware of my intentions.

I'm going to keep monitoring this thread and not bother you guys with off-topic talk :slight_smile:

After being able to sysupgade I have (force) pushed the changes to the same branch wax206/flashable-1Gbit as before mentioned.

1 Like

nice work. thanks!!!
time to use my router finally

@lynxis has most recently touched the combination of MediaTek SoC and RealTek 2.5G PHY. I understood that the PHY needs the MAC to switch speed between SGMII for 10M/100M/1G mode and 2500Base-X for 2.5G mode. We may still miss some patches for this to work.

Thank you @daniel, let's see if @lynxis find its way to this thread. He did reference a potential patch for this in MTK830 + RTL8221B-VB-CG 2.5G question. Unfortunately the code doesn't get called for port@5 of the MT7531 in my tests.

If you don't have serial access then hold your horses :slight_smile: ... testing factory again this morning and I did break it (again) along the way.

Do you mean an error, that it is not finding the kernel at a given address?
I saw that error yesterday evening, but didn’t have time to look deeper into it.

In my case it's a kernel panic because of a missing 'root=' boot options. Since it did work I tweaked the wrong thing out of the factory image creation call.

boot log
[    2.442355] UBI error: no valid UBI magic found inside mtd7
[    2.448871] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    2.456350] Please append a correct "root=" boot option; here are the available partitions:
[    2.464716] 1f00             512 mtdblock0
[    2.464722]  (driver?)
[    2.471256] 1f01             256 mtdblock1
[    2.471260]  (driver?)
[    2.477786] 1f02             512 mtdblock2
[    2.477790]  (driver?)
[    2.484312] 1f03             512 mtdblock3
[    2.484316]  (driver?)
[    2.490846] 1f04            1024 mtdblock4
[    2.490850]  (driver?)
[    2.497376] 1f05           38912 mtdblock5
[    2.497380]  (driver?)
[    2.503901] 1f06            4096 mtdblock6
[    2.503904]  (driver?)
[    2.510431] 1f07           32768 mtdblock7
[    2.510435]  (driver?)
[    2.516961] 1f08           38912 mtdblock8
[    2.516964]  (driver?)
[    2.523485] 1f09            8192 mtdblock9
[    2.523489]  (driver?)
[    2.530014] 1f0a            4096 mtdblock10
[    2.530018]  (driver?)
[    2.536630] 1f0b            1024 mtdblock11
[    2.536634]  (driver?)
[    2.543242] 1f0c            4096 mtdblock12
[    2.543246]  (driver?)
[    2.549861] 1f0d            2048 mtdblock13
[    2.549865]  (driver?)
[    2.556473] 1f0e            1024 mtdblock14
[    2.556477]  (driver?)
[    2.563091] 1f0f            1024 mtdblock15
[    2.563095]  (driver?)
[    2.569707] 1f10            5120 mtdblock16
[    2.569711]  (driver?)
[    2.576319] 1f11            1024 mtdblock17
[    2.576323]  (driver?)
[    2.582936] 1f12            6400 mtdblock18
[    2.582939]  (driver?)
[    2.589552] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    2.597806] SMP: stopping secondary CPUs
[    2.601721] Kernel Offset: disabled
[    2.605198] CPU features: 0x0,00006000,00000802
[    2.609720] Memory Limit: none
[    2.616422] Rebooting in 1 seconds..

I tested the following update paths and they were sucessfull for me:

  • Netgear V1.0.1.5 EU > Web GUI > Firmware Update > OpenWrt factory image (*.img)
  • Netgear V1.0.4.0 EU > Web GUI > Firmware Update > OpenWrt factory image (*.img)
  • OpenWrt > LuCI GUI > Flash new firmware image > OpenWrt sysupgrade image (*.bin)
  • UBoot > System Load Linux to SDRAM Via TFTP > OpenWrt recovery image (*.itb)
  • OpenWrt recovery image > LuCI GUI > Flash new firmware image > OpenWrt sysupgrade image (*.bin)

For the OpenWrt sysupgrades I did not keep the settings.
It seems a local, not commited change f-ed my sysupdate image. There was a small error in the device tree which I did correct and push.

Random info:

On my router the factory backup image is V1.0.1.5 EU. If I mess up something and want to restore the Netgear factory backup image the following works:

  1. connect to serial console of WAX206
  2. interrupt boot to stay in the boot menu
  3. choose U-Boot console
  4. in the prompt enter bootm and hit return

It seems that since there's no kernel loaded at this time the factory backup is then restored automatically.

4 Likes

Tried doing it using the physical button on the 206 ? Press it > 10 sec.
Would be good to know if roll back from OpenWRT works, without console access.

Good idea, just tested it. But it does reset the OpenWrt configuration.

Flashing back to the Netgear firmware works with nmrpflash. That way, serial access is not necessary.

2 Likes

Forgot about nmrpflash and it is easy enough, indeed.

Your Tree builds and the images boot succesfull. Did you anything regarding the wirelessinterfaces by now?

Nope, haven't touched that. That's the area I have the least knowledge about.

There's no compatible in your dts. Maybe it works when using the same chunk from mt7622-linksys-e8450.dtsi?

&slot0 {
	wmac1: wifi@0,0 {
		compatible = "mediatek,mt76";
		reg = <0x0000 0 0 0 0>;
		ieee80211-freq-limit = <5000000 6000000>;
		mediatek,disable-radar-background;
	};
};

Just new to openwrt, after update with the flashable image , how to make the device to internet

tried to make wan as eth0 , but it does not connect the internet

you shouldn't have, the buildable images are experimental, at best.

IMHO

Thanks you, I'll give it a go tomorrow and let you know.