OpenWrt support for Luckfox-Pico-Max, For only $14.99, very cheap openwrt router

Introduction

LuckFox Pico 、Luckfox Pico Mini A/B and LuckFox Pico Plus are low-cost micro Linux development boards based on the Rockchip RV1103 chip, while LuckFox Pico Pro and LuckFox Pico Max are low-cost micro Linux development boards based on the Rockchip RV1106 chip. RV1103/RV1106 is a highly integrated IPC visual processing SoC designed for AI-related applications. It is built on a single-core ARM Cortex-A7 32-bit core with integrated NEON and FPU, and features a built-in NPU that supports INT4/INT8/INT16 mixed operations, with a computing power of up to 0.5 TOPs.

Furthermore, it features a new hardware-based ISP that supports various algorithm accelerators such as HDR, 3A, LSC, 3DNR, 2DNR, sharpening, haze removal, gamma correction, and more. Additionally, it has a built-in 16-bit DDR2 DRAM to maintain demanding memory bandwidth, as well as built-in POR, audio codec, and MAC PHY. In essence, the RV1103 is a powerful processor suitable for various AI application scenarios.

This development board is suitable for applications in various scenarios, including but not limited to:

  • Smart home devices
  • Industrial automation equipment
  • Robots and drones
  • Intelligent monitoring devices
  • Intelligent transportation equipment
  • Smart medical devices

The development board supports multiple interfaces, including GPIO, UART, SPI, I2C, USB, etc., facilitating rapid development and debugging for developers.It's worth noting that the entire LuckFox Pico series development boards support both buildroot and Ubuntu 22.04 systems, allowing developers to choose the appropriate system based on project requirements, providing greater flexibility to meet specific application needs.

Product Parameters

Luckfox-Pico-quick-start

Ref:
https://downloads.openwrt.org/snapshots/targets/bcm27xx/bcm2709/
https://openwrt.org/toh/raspberry_pi_foundation/raspberry_pi
https://techinfodepot.shoutwiki.com/wiki/RPF_Raspberry_Pi_series

Luckfox-pico-max firmware download

download upgrade_tool

sudo ./upgrade_tool uf Luckfox-Pico-Max-for-openwrt/IMAGES/update.img

vi /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	#option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option proto 'dhcp'

With a single 10/100 ethernet port and no Wifi, "routing" appears to be a fairly theoretical scenario.

2 Likes

Modify the relevant device tree to set the USB mode to host mode, Can support USB WiFi

&usbdrd_dwc3 {    status = "okay";    dr_mode = "host";};

You can refer to it

I will gladly change my assessment accordingly, from theoretical to academic.

1 Like

If you need to connect USB WiFi (and given that many USB WiFi doesn't work as AP nor supported under OpenWrt now), I don't see the point of using it as router.

Also you need Pro/Max variant to have 128-256MB ram, other variants only 64MB ram which is no good, the overall package here doesn't look good when compared to RPi Zero W/2W.

@xiaobo why are you stuck using that kernel version?