OpenWrt Support for Banana Pi BPI-R3

Thanks. Done so. Just to let all know that my IP-tv isn't working anymore, although I uploaded the config I downloaded before upgrading from rc1 to rc3.

Edit: Solved. IGMP proxy package needed to be installed manually.

Finaly i fixed my problem with my ONT not working.

all you had to do was connect the fibre, without which it was impossible to ping the module!

2 Likes

Hello,

My BPI-R3 is working great with the,
openwrt-23.05.0-rc3-92a7d087de39-mediatek-filogic-bananapi_bpi-r3-sdcard.img
Many thanks to those who has made this happen.

Though, I do note a problem...

In menu item Status, Channel Analysis, there is no update, and in a short time, I get Session timeout, it logs me out, and I have to relogin.

Hello,

Do I have to enable something to make the Ethernet ports 2.5GB ? Doesn’t seem to work for me. I have verified cables, and switch port. I am using image, openwrt-23.05.0-rc3-92a7d087de39-mediatek-filogic-bananapi_bpi-r3-sdcard.img

Everything seems to work, though, haven’t tested the 10GB Ethernet ports, yet…

From menu item, Status, System Log,

Mon Sep 11 15:09:28 2023 kern.info kernel: [ 1645.894856] mt7530-mdio mdio-bus:1f lan1: Link is Up - 1Gbps/Full - flow control rx/tx

From the BPI-R3 forum:

frank-w:

There are no 2.5g “ports”…the sfp cages have 2.5g backend. Here should be noted that right one is connected to switch which also serves the 5 rj45 ports (1g) and also connected with 2.5g to cpu. So having traffic on the rj45 ports will reduce traffic on lan-sfp.

10gbit/s? Upcoming bpi-r4 will have 10g sfp+ ports,but on r3 these are max 2.5g

Ahh, there’s my “problem”, rushing into things again...

I am trying to achieve the same but with default selinux-policy in dssp im having trouble with wifi

Hello. Do you think OpenWrt is stable enough for a daily driver @VA1DER ?
Will be used as a router and qosify cake.

Today I’ve the apu2 but I want hardware offload, and this one has it if I’m not mistaken.

Thanks.

cake and offloading is at odds. While cake and software flow-offloading (which is available on all devices) 'works', the offloading effect converges to zero while sqm/ cake is active, as pretty much everything needs to be under control of sqm and takes the non-offloaded slow path. sqm and hardware flow-offloading (as offered by this hardware) is not possible, at all. What remains, is the normal non-offloaded performance of the device, minus the overhead necessary to cope with sqm.

Ah, okay :+1:. Thanks for the info.
So that’s where nss comes in, to be able to use hardware offload and cake in harmony?

No, NSS doesn't support cake at all (so not offloaded either).
NSS does support a variant of fq_codel (but vanilla OpenWrt doesn't support NSS…), which is a different/ simplified QoS algorithm, but don't ask me about the detailed interactions with qosify in the mix, my guess would not be positive.

N95/ N100 (or better) x86_64 based systems sound more sensible for this use case, or more generically said, something with enough performance not to require offloading of any kind (with a healthy margin on top).

[but that is all quite far away from the device that would be part of this topic]

Well that’s good to know. I have a nuc compute element I can upgrade. I’ll see what’s available and take it from there. Cheers!

i get A+ on bufferbloat test without qos, with HW offloading + WED, on a 2gbps fiber.

1 Like

How many queues does each lan and sfp port have? Is it 4 on each? Thinking of RSS support.

Which command display this ?

ethtool -x eth0

It will show queues if supported. Use lower x.

Hi, I own a Banana Pi BPI-R3 with 2x SFP 2.5G-T from the official shop. My computer has a 1G onboard card and is connected to the LAN SFP module which works just fine. I'm using a DOCSIS 3.1 modem also with 1G ethernet. Connecting it to the 1G WAN port@banana works fine but connecting it to the 2.5G WAN SFP@banana doesn't. I just get a few tx with no rx and no DHCP IP is assigned. What could be wrong?

this is what i have :

root@OpenWrt:~# ethtool -x eth0
Cannot get RX ring count: Not supported
root@OpenWrt:~#

SFP1 is ETH1, is it in your br-wan ?
try to remove the wan port from your br-wan, and keep only eth1 in it.

Can you post your /etc/config/network file ?

Everything is pretty stock, so yes br-wan is eth1 and wan. And removing wan from br-wan doesn't fix the issue.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd09:5488:e5a4::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'sfp2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'br-wan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'wan'

config device
	option name 'eth1'
	option macaddr '46:6e:f4:cc:bc:18'

config device
	option name 'wan'
	option macaddr '46:6e:f4:cc:bc:18'

config interface 'wan'
	option device 'br-wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'br-wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

Thanks. :+1: