OpenWrt Support for Armor G5 (NBG7815)

Thx! I was not aware that there is a patch available. I will give it a try for sure and see how it works. The approach to work with hysteresis is more elagant then what we have atm. While the vanilla users do not have anything. What needs to be done to get this into OpenWrt? Just a pull request or open an issue first?

Or is the simpler/easier approach from either @itorK or @avalentin better for trying to get it into OpenWrt?

Well, I have to say sorry to you! I didn't pay attention that you are refering to WIFI only. We had this MAC issues at the beginning with WAN and LAN. That is solved by fixing the DTS file. The outdated values are still within developers repo's. While I'm using fixed MAC's/BSSIDS for WIFI to force clients to 5G or 2.4G only I was not aware that MAC's for WIFI are chaning on every reboot.

So this is clearly a bug and worth to open an issue.

While I get an output on AX3600 for "cat /sys/class/net/wlan*/address" the value is non-existent on NBG7815 (tested on vanilla OWT without any modification). There should be a wlan not the pyh's only.

Just make a PR, this is the better solution as it does not depend on any kind of script or hardcoded paths and will just work.

Basically, you just need to find the sweetspot at what temperature the fan is optimal to turn on and that is is, especially since its just on/off GPIO fan

Good morning to all!!!
I just bought this router because on Amazon Italy it has a really low cost (now it's at €89.90) and its technical characteristics for this price are truly remarkable.
I see in your posts that you are trying to solve some hitches but I don't understand what is the best snapshot to install at the moment.
Better the one in the official repo or that of some of you? Which one exactly?
Also I was reading that the wiki might have some "out of date" that right?

Thanks for your great work!

Does anybody know what is the exact eMMC model in this device?

It seems that it has broken TRIM like the one in Qnap 301W and its only now poking up since 6.1 is using TRIM to try and offload erasing blocks.

This maybe help you

Thanks, that helps

I am trying to mesh NBG7815 (main router) with Xiaomi AX3200/AX6S (AP) on 5GHz. Mesh configuration is successful and I see the connection is established. However, no communication at the L3 level (ping, trace, route, etc.) is provided. Devices connected to the AP can get IP addresses via NBG7815. There seem to be a few known problems for the mesh between the Ath10k and the MT76. Similarly, is there a known problem with Ath11k?

For example;

Ath10k-firmware-qca988x mesh issue (same as)


I am no WIFI expert, so no clue

Fyi, I've just built an image based on @asvio 's repo (thanks!), adding the fstools block patch to allow extroot to an mmc partition. The patch works as expected after sysupgrading without keeping the settings (probably I messed up something in the first try and borked up the configuration).


Can you share the repo or firmware link? As I understand it the repo is the copy of the latest master branch. Also, led and fan driver included. How can I build using this repo?

It looks like the problem here. Maybe this will give you an idea.

Hi guys, correctly configured PPPoE WAN.

config interface 'wan'
	option proto 'pppoe'
	option username 'XXX'
	option password 'XXX'
	option ipv6 'auto'
	option device 'wan.835'

But the performance are lower than old ISP modem. Speedtest shows 550 on openwrt and 900 on isp modem. What cloud be the problem. The ISP is TIM Italia.

Do you enabled "Packet Steering" (Enable packet steering across all CPUs. May help or hinder network speed.)?
What MTU did you set, and what did you have set on the old modem?

no and i think the problem is that i'm using only one core. Where can i enable Packet Steering?

If you are using luci, You can find it under: Network -> Interfaces -> Global network options

1 Like

Still not using all 4 core and 100% load on 1 core but it increase a lot pppoe performance thanks.

Hello, @psychowood and to all of you who have used some of my forks that include the modification of the fan support.

There was a typo and a permissions error in the file that prevented it from running correctly and as a result the fan would not turn on when the designated temperature was reached.

Now the bug is fixed in all forks except nbg7815-nss repository

For those who already included the previous commit in their own build, copying the new file to target/linux/ipq807x/base-files/sbin/ and generating a new commit would be fastest way to update.

I'm sorry for the inconveniences.

EDIT: Fan bug is now also correct in the nbg7815-nss repository. There you can see what are the changes

1 Like

Mine is based off asvio's repo (note the branch, G5 stuff is not on main), with added fstools block patch for extroot. I have a working image built but I honestly don't feel confident enough to share it :slight_smile:

If you have docker it is quite simple to do it yourself, you can use docker-openwrt-builder and follow the instructions, besides changing the cloned repo (and checking out the correct branch).

@asvio thanks for the heads up on the fan typo, no worries since the fan wasn't working anyways before :smiley:

1 Like

Thanks for information. I prepared the environment for the build. There are several branches in @asvio repo. Which branch should I choose?

hi, thanks all for the support. i have this router and install last zyxel_nbg7815-squashfs-sysupgrade and Luci. I have a question, inside this firmware, the optimization for cpu,led, fan,etc are implemented or i need to install in other way? if is not implemented is possible to have a list of this command/code? thanks all

@asvio can you help me in this questions? thanks