OpenWrt on TP-Link EAP120 - Not recognised by router, no internet


#1

Hi all

Recently acquired an EAP120. Worked with the stock firmware, but I wanted to try OpenWrt.

I installed it fine and set it up as an access point per this guide: https://openwrt.org/docs/guide-user/network/wifi/dumbap

It worked, but there's no internet. I can't see it in the device list of my Netgear DM200, and I can only access LuCI by connecting directly to the router (it won't work connected to my switch).

Any ideas?

Thanks.


#2

There may not be enough info to diagnose here, but first:

If you're configuring as a dumb AP, you must have a cable connecting the LAN port on your main router going to the LAN port on the dumb AP. If you connected it to the OpenWrt WAN port, the dumb AP functions won't work.

In addition, if you want to access the OpenWrt dumb AP, the LAN network must be the same as the main router -- you can manually assign the IP as long as it is not in the main router's DHCP range and is not otherwise being used. If the OpenWrt device itself needs internet access, be sure to set the system DNS and gateway consistent with your main network (this is not required for the dumb AP to work in general).

If this doesn't solve your issue, please post the contents of these files:
/etc/config/network
/etc/config/wireless (you can obscure the passwords)

and also please let us know what the IP address (or network definition) is for your main router/LAN.


#3

Thank you for the quick response.

My router and AP only have one ethernet port on them. I connected the port on the router to the one on the AP, but this meant I can't access my router's GUI, only the APs.

My router is 192.168.5.1 and I configured it to be 192.168.5.5. I didn't change any DNS settings, but i set the gateway to be my router's IP.


#4

Make sure that the ap has the Ethernet port configured as a lan port, not wan.


#5

I think it's set to LAN.


#6

More than likely you’ve got the Ethernet port configured as a wan.

Please post the files I requested earlier as well as one more:
/etc/config/firewall


#7

Will do when I am home.


#8

Here it is:

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd64:67ec:8d81::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.5.1'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

/etc/config/firewall

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fc00::/6
        option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

only changes i made were enabling wifi and pointing it at my router's gateway.


#9

Thanks for posting your files.

Try this: Change the IP address from 192.168.1.1 to 192.168.5.5


#10

I had it like that earlier, but for some reason when I do it now I can't access LuCI or connect via SSH. I'll try again though.

update, tried it, same result :confused: i'll try it again without turning DHCP off like the guide said


#11

Successfully changed the IP address, but that makes no difference. I can't load LuCI from the wifi connection, either.


#12

What's the IP address of the router? Is it 192.168.5.1?

Can you ping an outside IP (e.g. 8.8.8.8) form your AP OpenWrt GUI interface or SSH? This could help to eliminate DNS issues.


#13

And, most importantly, can you ping the router from the AP?


#14

Out of curiosity, what IP does your PC get if you were to connect the PC to the LAN port of the DM200?


#15

Yes, the router is 192.168.5.1.

No, I can't ping any IP address nor the router from the AP.

I got 192.168.5.113 when I connected my laptop to the router directly.


#16

What version of OpenWrt are you running? Did you manually edit the firewall file?

I don't know if it makes any difference or not, but you have in your firewall, for instance

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

While mine, on 18.06.01 says:

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

I don't know if the syntax changed between versions or if it doesn't make difference (I'm not a Linux guy), but you could try that.


#17

Could you post a screenshot of your http://192.168.5.5/cgi-bin/luci/admin/network/network
(you may mask your MAC address)


#18

Here it is.


#19

Did you do anything on the VLAN?
http://192.168.5.5/cgi-bin/luci/admin/network/vlan. A screen shot would be good.


#20

I just get a 404 when I try to access that.