OpenWrt on TP-Link EAP120 - Not recognised by router, no internet


#21

You have no Internet - because 192.168.1.0/24 and 192.168.5.0/24 are not the same subnet.

Your gateway is invalid.


#22

He presumably changed the AP IP to 192.168.5.5, so that should be covered.

@_haru Could you confirm that you access the AP now form 192.168.5.5?


#23

Tru.

That's your gateway then, this is an upstream device, correct?

I did see you changed the OpenWrt to 192.168.5.5.

Also, please say you disabled DHCP on the 192.168.5.5 OpenWrt device. Otherwise, any device getting a response from it, incorrectly thinks the OpenWrt is the gateway.


#24

Yes you have to disable the DHCP server in your dumb AP, otherwise it will conflict with the DHCP server in the main router. The main router will tell devices that 192.168.5.1 is the gateway to the Internet, which is correct, but your dumb AP (improperly configured) will tell them that 192.168.5.5 is the gateway to the Internet, which it is not. So some devices on the network will "not have Internet" because they were configured by the wrong DHCP server. This will affect both wired and wireless users. After fixing the AP configuration, you need to disconnect and reconnect those devices so that they pick up a correct DHCP.

Also in the LAN configuration you need to add option dns to 192.168.5.1 so the router can look up DNS names. This is important when the router OS itself needs to fetch data from the Internet such as the NTP time and package downloads.


#25

But he says that OpenWrt cannot ping the modem.

I was thinking maybe something with VLAN.


#26

@lleachii
I think I did.

@mk24
alright. how do i do the dns thing?

and yes, i have fixed it to be 192.168.5.5.

I reached my post limit. I'll try all of your suggestions. How do I renew dhcp?

Okay, reset the leases. Still no internet.


#27

I assume the OP is plugged into eth0 - upstream (where is the switch).

If you just did it, ALL leases must be renewed ON ALL CLIENTS.


#28

No.

Only one port.

https://openwrt.org/toh/hwdata/tp-link/tp-link_eap120


#29

Yes, I know it's one port, but is it possible that for some reason VLAN is enabled, but eth0 and LAN aren't on for the same VLAN?


#30

Reset all network interfaces - wired and wireless. Reboot the Dumb AP, etc.

Tru...but default lease on OpenWrt is 12 hours, this issue must be eliminated 1st for the OP.


#31

Please refrain from editing posts to show future events.

We'll have to resume later - or wait until you perform other tasks to increase your user level.


#32

This device does not have a switch chip (the AR8035 is a one-port PHY chip only), so VLANs would only need to be set up directly on eth0. Using plain eth0 with no VLAN number means that untagged packets will go out on the cable.

I would also make sure the IPv6 DHCP server is disabled, this is a separate tab on the DHCP section at the bottom of the LAN network configuration page.

Check network status on the end-user devices to see that they are properly DHCP configured.


#33

Okay, I'm back. I'm not sure if DHCP on the computer is the issue, since my router doesn't even detect the device. However, the lan port works since the AP can tell when i turn on/off the router.


#34

Could you try another cable?


#35

tried :frowning:


#36

Ok it's getting a bit confusing. You have Router, AP and PC.
As I understand, router is 192.168.5.1, AP is 192.168.5.5. Let's set the PC to static IP of 192.168.5.10.
Connect the PC directly to the router. Can you ping it?
Connect the PC to the AP. Can you ping it? Can you ping the router?


#37

I can ping the router without issue.
I can ping the AP directly when I'm connected to it directly, but not when both the PC and AP are connected to the switch.


#38

Let's remove the switch now to simplify things.
Disable DHCP on the AP, connect it to the router and see if you can ping the router from the LuCI or SSH.


#39

Didn't work.


#40

Have you disabled DHCP on the AP?