OpenWRT on Dynalink WRX36 VLAN Problems

Reference: [Solved] RT-AX53U Bridge/VLAN Config

This got me working just fine with the RT-AX53U, but attempting to get the same VLAN setup working on the Dynalink leads to losing connectivity every time as soon as I apply the VLAN config. I am running RC2 (and not the snapshot), which has Luci built-in and the install itself was pretty straight-forward -- but I am once again pulling my hair out attempting to get two VLANs to work (the base, Vlan 1 but don't care as its untagged) and then on Vlan 3 for the guest network.

Its a different hardware base in the switch, but you'd think it would be basically the same in both cases -- but it isn't, and what worked perfectly well for the RT-AX53U doesn't on this device. Trying to do it entirely through Luci fails, as does editing the config file by hand; both lead to the same result.

In fact, just setting "u*" for VLAN 1 for the br-lan interface, which should default it to untagged, VLAN 1 leaves me with nothing immediately at all when connected to a standard PC on one of the LAN ports; after the 90 seconds with Luci it reverts of course.

Is there something odd with the WRX's switch involved in this?

The Dynalink uses DSA, I think:

The Asus is probably still using swconfig so that is totally different perhaps that is the problem?

I hard-reset the Dynalink and did it again in the config files and now it appears to be working - Luci still gets it wrong but I'll mark it fixed since it is working.... other than the "gotta be careful installing the software" caveat I really like this little box; on a bang-for-the-buck basis its hard to beat.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.