OpenWrt on a TP-Link TL-WA701ND V1

I have here a TL-WA701ND, and I tried to flash openWRT on it. I connected it via tftp to a computer, and also via serial port and screen.
I used this commands:

setenv serverip
tftpboot 0x80800000 firm.bin
erase 0x9f020000 +0x3c0000
cp.b 0x80800000 0x9f020000 0x3c0000
bootm 0x9f020000

flashing looks good. no failure. But after reboot there was a failure:

kernel panic - not syncing

and it boots again, and again, and again

I tried

I'am not sure if I used the right address. I'am able to get acces to the failsafemode. Is there a possibility to do some checks in failsafemode? Could it be that the memory is "defect"?


Hi, in the failsafe mode i tried to check the memory with the command

df -h

There is only 2.3MB and nothing free. Does that mean, the memory is broken?

This device does not have enough flash or RAM to do much useful with OpenWrt. Running old versions is not recommended due to security issues.

To answer your question though, in failsafe mode the writeable part of the flash, (/overlay partition) is not mounted until you run mount_root.

You may want to run sysupgrade -n and reflash with the sysupgrade file to be sure you have a good install in flash. When writing directly to flash, the sysupgrade file is used, not factory. I'm not sure how it boots at all after what you did.

For this sysupgrade in need network connection right? I think I don't have. There is no ping available.

Is it possible to make this sysupgrade from RAM?