OpenWRT OFDMA, MU-MIMO, BSS Coloring, Beamforming, and TWT switch ON/OFF

Hi,

I'm a student currently working on my engineering thesis.
I wanted to explore the impact of factors like OFDMA, MU-MIMO, BSS Coloring, Beamforming, and TWT on network speed. I was wondering if there's a way to toggle these options on and off. I'm currently using OpenWRT 23.05.3 on Xiaomi AX3200 router model RB01. I tried looking for these options in the graphical interface but couldn't find them.
Are there any libraries or configuration files where I can make these changes? Or maby you recommend any other software that would allow me to change all these settings?

Thanks in advance for your help.

You need to disable ax to remove mandatory color field. Rest is written in wiki.

1 Like

By disable ax, you mean to switch it to ac?

I was trying to find those options. "Rest is written in wiki" isn't really helpful for me. I'm new to OpenWRT, so if you could provide any additional information or a link, it would be nice.

You need to override all he_caps vht_caps and ht_caps
Caps are in /var/run/hostapd*.conf , you can pass modified version with unwanted caps disabled.
https://openwrt.org/docs/guide-user/network/wifi/basic
Cisco keeps good descriptions on what each means, or you can acquire standards via your educational establishment.

2 Likes

I had seen topic with /var/run/hostapd*.conf, that was also what chat suggested me, but when i enter my files on PuTTy i dont have any conf files like this, I use OpenWRT 23.05.3
image

root@DL-WRX36:~# ls /var/run/hostapd*.conf
/var/run/hostapd-phy0.conf

1 Like

image

Wireless disabled or not started?

You can check with:
wifi status

root@R7800-2:~# wifi status
{
        "radio0": {
                "up": true,
1 Like
grep _capab= /var/run/hostapd*conf
/var/run/hostapd-phy0.conf:ht_capab=[LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935]
/var/run/hostapd-phy1.conf:ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935]
/var/run/hostapd-phy1.conf:vht_capab=[RXLDPC][SHORT-GI-80][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][SOUNDING-DIMENSION-2][BF-ANTENNA-2][MAX-MPDU-7991][MAX-A-MPDU-LEN-EXP7]

you are right, i didnt know wifi is disabled by deafult
now its working
image

2 Likes

If you are satisfied and have a working solution for your use case please mark that solution as solved:

:slight_smile:

1 Like

actually, I haven't managed to figure out how to disable individual options yet, so I'll leave the thread open, I'm currently working on editing these files:

All options are here: https://w1.fi/cgit/hostap/tree/hostapd/hostapd.conf
You need to pass them via /etc/config/wireless to these generated files.

What do you mean by pass them via /etc/config/wireless?
I've changed this file:

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'psk2'
option key 'xxx'
option he_mu_beamformer '0' --- new line

After save and reboot my hostpad*.conf didnt change:

image

Is it something wrong or should i directly change the hostpad*.conf file?

You need to restart wpad service or wifi radio