OpenWrt installation on Edgerouter X

Hi, I have just joined, been lurching for a while....I was looking for an idiots guide to installing OpenWRT on my Edgerouter X I have read the thread on installing it and I can't get it going, I tried installing the initramfs bin file using Edge OS Web GUI and it says not compatible, most instructions seem to include commands and I don't know where and how to execute them.
I was happy with Edge OS but as a beginner I find the changes to their forum too much for me to navigate and find things out now, the new official firmwares seem to break more things than it fixes so I'm trying to put OpenWRT on it, I have used OpenWRT before but the device either came with already installed or was a Web GUI upgrade.
Sorry for such a basic question. TIA.


@gmangt4, welcome to the community!

Do you have a Linux machine and are you comfortable using SSH and SCP commands?

Thanks for the welcome.
I only have windows laptops, I do have putty and the Edge OS has a CLI option if thats any use?

Do you know already ?

1 Like
  • You first need a program capable of SCP to transfer the image, FileZilla should work.
  • You can then use PuTTY to connect via SSH, then run the subsequent commands:
cd tmp
add system image openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar

(BTW, you can use one post to respond to multiple persons.)

1 Like

Yes, I've read that and the other thread but it all seems foreign to me
I tried to use the install file from that page but the router says its not compatible when I try from the Web GUI screen, its a bin file and I'm not sure if its looking for a tar file

I have filezilla as use it a lot for sending stuff to Enigma2 boxes...what do I do with filezilla?, connect to the router and then add the install bin file to a folder? Can you point me in the direction of what directory?
Sorry, I'm just learning this forum and wasn't sure if could multi quote, cheers

  • Did you read the OpenWrt Wiki link that @tmomas posted?
  • Did you see the commands posted above?

(FYI, the folder is /tmp.)


Just use the proper file name, simple. Let us know your results.

Ok folks, thanks, your input is VERY appreciated, I'm going to try this later using Filezilla as I never tried that and I'm used to using it.
I have read the link posted many times before posting, I'm struggling to get started with where to put things and what programs to use to perform the commands but I know some more now thanks to you guys.
I will report back on how I get on

Sorry, another question, the one I've downloaded ends in .bin and not .tar, does that matter?

Mine was installed using the .tar file found over on Ubiquiti EdgeRouter X, Loading OpenWrt and performance numbers

I found that thread really helpful for install


Just curious: Why is everybody using the initramfs-factory.tar when there are already (and only) prebuilt initramfs-kernel.bin images available?

And why are the buildbots building bin and not tar, as one would expect when reading this (end of the highlighted line #466)?

Not exactly your device, but close enough:

Mentioning of the kernel.bin instead of tar (already back in 2017, an still today the bin is being built, not the tar):


@hecatae I tried it last night after finding that link but I get a 404 when clicking on it, does it work for you?
@tmomas I don't know the answer the initramfs one I download is a .bin file but I keep seeing reference to .tar, it confuses me tbh.

This was an known issue recently, it should be fixed now.

Also see: [solved] server configuration | 403 forbidden

Still 404 not found for me :frowning:

You sure?

1 Like

Thanks, they ones are working, I was clicking on the links from the posted threads, thank for being patient, I'm new around here and trying to learn and hopefully contribute at some point.....might be a while yet :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.