[solved] Openwrt.org server configuration | 403 forbidden

Hello there,

could anyone from the openwrt.org team check the (web-/file-)server configuration?

  • Personally my router got a problem updating the opkg lists:
opkg update
Downloading http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/base/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/base/Packages.gz
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/base/Packages.gz, wget returned 8.

Maybe a "global" misconfiguration somewhere?
@thess : ping to you, as you've answered in the other thread given above


edit01: cosmetics/formatting

1 Like

Hi! When I try "make image" command I get the following error:

opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/base/Packages.gz, wget returned 8.

I tried to open it in browser and it really returns 403 Forbidden.
And now I'm unable to make image for my mikrotik rb951ui.

Please, help!

Got the same issues. :frowning:

1 Like

@tmomas can you check the OPKG packages server again? The issue with the 403 forbidden currently occurs and has to be fixed again.

When I try to access http://downloads.openwrt.org/releases/18.06.2/packages/mipsel_24kc_24kf/base/Packages.gz I get the 403 Forbidden. It seems that only the packages in the base folder are effected. The others work fine.


I also have found the same issue, but in https://downloads.openwrt.org/releases/packages-18.06/mipsel_74kc/base/, including but not limited to packages.gz.

The 403 is intentional, we have problems with corrupted base repositories and decided to take down broken directories to prevent people from bricking their devices.



thank you for the info

And when everything will work again?


When it's fixed, I believe.

I am sure that the guys are working on it, and I am sure when they fix it they will tell us.


You can follow the build process here:

Once everything is verified to be correct, I'll re-enable repository access. This will most likely happen around 04:00 UTC tomorrow.


If this is the case then I would say that the openwrt ci/cd is broken badly. Download repos should always be complete and online - if the build system has problems then update of official repos should be stopped until problem is corrected.
Now, what happened today was very annoying. The repos went down meanwhile I was updating the system - causing the system being half-bricked.

I agree, problem is that it was noticed too late, mainly because the builds technically completed fine but built the wrong branch so the failure wasn't obvious.

I am not affiliated in any way to Openwrt, but I simply can’t understand why people do not bother to check the forum about the outage more in details before bashing out.

Firstly, Openwrt does not owe anyone a living or vice versa. Anyone should know that when they flashed an third party firmware over the original factory firmware, they have void the manufacturer’s warranty (everything at own risk) and stopped screaming around like a crybaby that the device almost got bricked.

The Openwrt folks are doing a great job and when it is fixed, it will be fixed, period. Shit happens and please stop all the annoying complaints and let the people fix their stuff. They do not owe you a living!


Same issue, please help me

Wait until the repos are fixed (there's no way around this anyways, unless you want to build from source), then you can (should!) sysupgrade OpenWrt (ideally to 18.06.3, but re-flashing 18.06.2 again would also work) and install your additional packages.

1 Like

The repositories are fixed now and access has been restored.


@jow hey, thanks for the short response time and for solving the issue!

If somebody also run into this issue this could help you. But configuration is LOST if you don't have a backup. Fortunately a backup of the configuration was made recently.
I could recover my Openwrt 18.06.2 based router by

  • Entering failsafe mode
  • Connect via SSH
  • Run firstboot
  • Reboot with reboot -f
  • Import configuration backup via Webinterface
1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.