Openwrt für my old Dlink DIR-505

I flashed it with the latest openwrt -Firmware and i can access it attached to my PC.Actually I want to use it as AP. My "Master-Router" is a FB6591 (
I activated on the DIR wireless and changed the br-lan to fixed IP 192.168.179.x, deactivated DHCP, Firewall, Masquarading and Mss Clamping. Depowered and attached the Lan to the FB. The WLan is working,but i cannot reach the DIR , neither through Lan nor Wlan.

@errut, welcome to the community!

I have a feeling you deleted too much. It should work with a:

  • new static IP (which you changed)
  • disabling DHCP

You may have broken something with deleting/disabling/editing firewall and masquerade.

Make sure you can reach it via LAN before connecting it to the "FB". You will have to set a static IP on your client.

Thanks for your comment.So I left it unticked . I read somewhere, that it is normal in bridged mode,that you cannot reach the router.
I can reach the Dir directly attached to my pc.
Attaching it to the FB shows the relevent IP in the net of the FB.
I have Internet with DIR, the IP´s are set by the FB.

I don't know what tick you're talking about or what's normal/not in bridged mode. Everything you need for an AP can be easily done by:

  • and plugging into LAN (which you did)
  • obviously setting up an SSID

This is pretty much common for all consumer-type routers. So, I'm unclear if that means you're still having an issue; or if you fixed it. You can always reset the device to default and try again. :wink:

(btw, you replied to yourself or to the original post, so I wasn't notified you responded)

According to referenced source, above problem is normal.

Using the OEM-Software there is no problem to open the AP.

I`m adding some more infos of may system. Maybe i find somebody to look over it
sorry i just found out no text-files for upload


Can you show the text on the linked page that says that 1.) there's a problem and 2.) it's normal?

I'm having trouble finding that text. In fact the page shows the AP has a LAN IP address, set in Step No. 1.


This is the same with OpenWrt - as long as you follow the same steps.

EDIT: Lastly, you do NOT have to run the config interface command in step 1. Only follow the steps above.

  • A LAN bridge already exists!!! :bulb:
  • Your device is NOT eth0

Do not perform any other not guess commands.

sorry i gave you the wrong Ref but can`t find the correct anymore.
maybe i misunderstand everything.
when i open first time, i find Interfaces BR-Lan,which i left as it is and added a new interface which i called WAN and enter IP 192.168.178.x, disabled dhcp and dnsmasque.After that i activated wlan.

This is what I thought you changed to 192.168.179.x and had WiFi bridged to.

I don't understand why you did this. No WAN should be involved nor needed; and again, the link you show doesn't match your statements.

1 Like

ok i found my error. I should have used BR-LAN .
Thanks for your effort

1 Like

I believe OP referred to the relayd tutorial. There the wifi clients connected to the OpenWrt are not able to access it directly and they need to have an extra static IP.

1 Like

Ok,everything is fine and running as i wanteit,also access through my PC.
Thanks again

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.